hdoj 4324 (Triangle LOVE )拓扑排序判断成环



题目大意:人与人之间的关系是复杂的,然而存在一种关系叫三角恋,即A喜欢B,B喜欢C,C喜欢A,需要注意的是本题中的三角恋只要存在三个或者三个以上的循环喜欢关系,都可以称为三角恋!

解题方法:典型的有向拓扑问题,即遍历n个点,每次判断是否存在入度为0的点,如果有一次不出现入度为0的点,即可判断已经成环!

 题目如下:

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3693    Accepted Submission(s): 1456


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 


ac码
<span style="font-size:14px;">#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
int indegree[2010];
char map[2010][2010];
int vis[2010][2010];
int n;
int topo()
{
	int k,v,i;
	
	for(v=0;v<n;v++)
	{	k=inf;  //每次k都要初始化 
		for(i=1;i<=n;i++)
		{
			if(indegree[i]==0)
			{
				k=i; 
			}
		}
		if(k==inf)  //只要有一次不出现入度为0就跳出 
		{
			return 1;
			break;	
		}
		indegree[k]=-1;
		for(i=1;i<=n;i++)
		{
			if(vis[k][i])
			indegree[i]--;
		} 
	}
	if(v==n) //v==n说明已经遍历了所有的点,说明均符合题意,即没有三角恋! 
	return 0;	
}
int main()
{
	int t,i,j;
	scanf("%d",&t);
	int k=1;
	while(t--)
	{
		memset(vis,0,sizeof(vis));
		memset(indegree,0,sizeof(indegree));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		 {	
		 	getchar();
		 	scanf("%s",map[i]);  //用字符型存储两两之间的关系 
			for(j=0;j<n;j++)	//在对字符串输入时,已经默认从0位开始的,这样就与它的下标意义不符 
			{
				
				if(map[i][j]=='1')
				{
					if(vis[i][j+1]==0)   //故必须用j+1表示两者的关系 
					{
						vis[i][j+1]=1;
						indegree[j+1]++;	
					}	
				}			
			}	
		 }		
		 if(topo())
		 printf("Case #%d: Yes\n",k++);
		 else
		 printf("Case #%d: No\n",k++);	
	}
	return 0;
}</span>



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值