HDU 4886 TIANKENG’s restaurant(Ⅱ)【hash+暴力】

HDU 4886 TIANKENG’s restaurant(Ⅱ)【hash+暴力】http://acm.hdu.edu.cn/showproblem.php?pid=4886

Problem Description
After improving the marketing strategy, TIANKENG has made a fortune and he is going to step into the status of TuHao. Nevertheless, TIANKENG wants his restaurant to go international, so he decides to name his restaurant in English. For the lack of English skills, TIANKENG turns to CC, an English expert, to help him think of a property name. CC is a algorithm lover other than English, so he gives a long string S to TIANKENG. The string S only contains eight kinds of letters-------‘A’, ‘B’, ‘C’, ‘D’, ‘E’, ‘F’, ‘G’, ‘H’. TIANKENG wants his restaurant’s name to be out of ordinary, so the restaurant’s name is a string T which should satisfy the following conditions: The string T should be as short as possible, if there are more than one strings which have the same shortest length, you should choose the string which has the minimum lexicographic order. Could you help TIANKENG get the name as soon as possible?

Meanwhile, T is different from all the substrings of S. Could you help TIANKENG get the name as soon as possible?
 

Input
The first line input file contains an integer T(T<=50) indicating the number of case.
In each test case:
Input a string S. the length of S is not large than 1000000.
 

Output
For each test case:
Output the string t satisfying the condition.(T also only contains eight kinds of letters-------‘A’, ‘B’, ‘C’, ‘D’, ‘E’, ‘F’, ‘G’, ‘H’.)
 

Sample Input
  
  
3 ABCDEFGH AAABAACADAEAFAGAH ACAC
 

Sample Output
  
  
AA BB B
 

Source
 

【题意】饭店起名字,已知一个字符串S,找一个字符串T使其满足:不是S的任一子串,且找到最短的串,长度相同输出字典序最小的~

【思路】hash+暴力:暴力枚举S的所有子串的值映射成9进制数,进行标记,找到没出现的最小的9进制换算成字符串输出~

【代码如下】

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 1000005;
int n,f[10],vis[maxn];
char str[maxn];

bool solve(int k)
{
    memset(vis, 0, sizeof(vis));
    int tmp = 0;
    for(int i=0; i<k; i++)
        tmp = tmp*8 + str[i]-'A';
    vis[tmp] = 1;
    for(int i=k; i<n; i++){
        tmp = tmp%f[k-1];
        tmp = tmp*8 + str[i]-'A';
        vis[tmp] = 1;
    }
    int x = 0;
    while(vis[x]) x++;

    if(x < f[k]){
        for(int i=k-1; i>=0; i--){
            printf("%c", x/f[i]+'A');
            x %= f[i];
        }
        printf("\n");
        return true;
    }
    return false;
}

int main()
{
    int cas;
    scanf("%d",&cas);
    f[0] = 1;
    for(int i=1; i<=8; i++)
        f[i] = f[i-1] * 8;
    while(cas--)
    {
        scanf("%s",str);
        n = strlen(str);
        int i=1;
        while(!solve(i)) i++;
    }
    return 0;
}


Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值