C 数据结构实验之链表七:单链表中重复元素的删除 SDUT

Time Limit: 1000 ms Memory Limit: 65536 KiB


Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。


Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。


Sample Input

10
21 30 14 55 32 63 11 30 55 30


Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


Hint
Source

不得使用数组!


链表中的元素删除与数组的元素删除不同,数组中的元素删除要将元素全部前移或后移,但是链表中的元素是要改变要删除元素前的节点的指针指向,但要注意改变的顺序,先改变前面的只想要删除节点指针指向的节点,在释放删除节点,也可以不释放

代码一:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int a;
    struct node *next;
};

struct node *creat(int n);
//链表建立;
void putout(struct node *head);
//链表输出;
void delete_(struct node *head,int n);
//重复节点删除;

int main()
{
    int n;
    struct node *head;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;//头结点的建立;
    scanf("%d",&n);

    head = creat(n);
    //建立链表;
    printf("%d\n",n);
    putout(head);
    //输出链表;
    delete_(head,n);
    //删除节点;
    putout(head);
    //输出链表;


    return 0;
}


struct node *creat(int n)
//链表建立;
{
    struct node *head,*p;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    while (n--)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->next = head->next;
        scanf("%d",&p->a);
        head->next = p;//逆序建立;
    }
    return head;
};



void putout(struct node *head)
//链表输出函数;
{
    struct node *p = head->next;
    while(p)
    {
        if (p->next)
        {
            printf("%d ",p->a);
        }
        else
        {
            printf("%d\n",p->a);
        }
        p = p->next;//注意不要遗落;
    }
}



void delete_(struct node *head,int n)
//重复节点删除;
{
    struct node *p,*pi,*q;
    q = head->next;


    while(q)
    {
        p = q;
        pi = q->next;
        while(pi)
        {
            if (pi->a == q->a)
            //删除节点;
            {
                struct node *r = pi;
                p->next = pi->next;
                pi = pi->next;
                free(r);//释放删除的节点;
                n--;
            }
            else
            {
                pi = pi->next;
                p = p->next;
            }
        }
        q = q->next;
    }
    printf("%d\n",n);
}


代码二:

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int a;
    struct node *next;
};
void show(struct node*head,int n)//链表输出函数;
{
    printf("%d\n",n);
    struct node *p = head -> next ;
    while(p)
    {
        if(p->next)
            printf("%d ",p -> a);
        else printf("%d\n",p -> a);
        p = p -> next;
    }
}
struct node *build(struct node *head,int n)//逆序建立链表函数;
{
    struct node *q;
    int i;
    for(i=0; i<n; i++)
    {
        q = (struct node*)malloc(sizeof(struct node));
        scanf("%d",&q -> a);
        q -> next = head -> next;
        head -> next = q;
    }
    return(head);
};



int main()
{
    int n;
    struct node *head;
    head = (struct node*)malloc(sizeof(struct node));
    head -> next = NULL;
    scanf("%d",&n);
    head = build(head,n);
    show(head,n);
    struct node *p = head;//删除重复节点;
    while(p->next)
    {
        p = p -> next;//每次后移一位;
        struct node *q = p,*qi = q -> next ;//两个游动指针一个对比一个辅助;
        while(qi)
        {
            if(p -> a == qi -> a)
            {
                q -> next = qi -> next;
                free(qi);  //释放已删除的节点;
                qi = q -> next;
                n--;
            }
            else
            {
                qi = qi->next;
                q = q -> next;
            }
        }

    }
    show(head,n);
    return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

碧羽o(* ̄▽ ̄*)ブ回雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值