Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

这个题目主要是哈夫曼思想,详情见离散数学一书,然后在这里主要用了01树杈
有两种解题方法,但是只要思想一样,然后一种是存储大数字,一种是用数组存储,第二种占用时间较少。

第二种:
同余模定理:

(a*b)%n = (a%n *b%n)%n;

(a+b)%n = (a%n +b%n)%n;

枚举前14个数字为:1 、10 、11、100、101、110、111、1000、1001、1010、1011、1100、1101、1110。。。

1110%6=(110*10+0)%6=((110%6)*10)%6+(0%6);

mod[x]=(mod[x/2]*10+x%2)%n;

第一种的主要算法也是mod[x]=(mod[x/2]*10+x%2)
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
long long m[600001];
int main()
{
    int n;
    int i;
    while (scanf("%d", &n) != EOF&&n)
    {

        for (i = 1;; i++)
        {
            m[i] = m[i / 2] * 10 + i % 2;
            if (m[i] % n == 0)
                break;
        }
        printf("%I64d\n", m[i]);
    }
    return 0;
}
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int m[600001];
int result[600001];
int main()
{
    int n; int k;
    int i;
    while (scanf("%d", &n) != EOF&&n)
    {
        m[1] = 1 % n;
        for (i = 2; m[i - 1]; i++)
        {
            m[i] = (m[i / 2] * 10 + i % 2) % n;  //哈夫曼,双向bfs
        }
        i--;
        k = 0;
        while (i)
        {
            result[k++] = i % 2;
            i /= 2;
        }
        for (i = k - 1; i >= 0; i--)
            printf("%d", result[i]);
        printf("\n");
    }
    return 0;
}

这个时候可能电脑编译器的原因,win系统和Linux系统的差异,我使用的vs2013并没有显示出正确的19的倍数的那个100位数,但是结果是正确的,这个是不用质疑的。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值