A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0 < N < 100 0<N<100 0<N<100, the number of nodes in a tree, and M ( < N ) M (<N) M(<N), the number of non-leaf nodes. Then M M M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID
is a two-digit number representing a given non-leaf node, K
is the number of its children, followed by a sequence of two-digit ID
's of its children. For the sake of simplicity, let us fix the root ID to be 01
.
The input ends with N N N being 0. That case must NOT be processed.
Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only
2
2
2 nodes, where 01
is the root and 02
is its only child. Hence on the root 01
level, there is 0
leaf node; and on the next level, there is 1
leaf node. Then we should output 0 1
in a line.
Sample Input:
2 1
01 1 02
Sample Output:
0 1
中文题意
给出一颗树,输出每一层叶子节点的数量,行末无空格。
思路
用一个结构体存树的每个节点。id代表节点编号,sz代表该子树个数,son[i]表示第i个儿子的编号。
层序遍历树的每一层,如果节点的sz为0,则代表是叶子节点,记录个数。
最后注意行末无空格输出。
AC代码
#include<bits/stdc++.h>
using namespace std;
struct T{
string id;
int sz;
string son[105];
}p[105];
unordered_map<string,int> mp; // id --> 数组下标
int n,m,root;
int main(){
cin>>n>>m;
for(int i=1;i<=m;i++){
cin>>p[i].id>>p[i].sz;
mp[p[i].id]=i;
if(p[i].id=="01") root=i;
for(int j=1;j<=p[i].sz;j++){
cin>>p[i].son[j];
}
}
queue<int> q;
q.push(root);
bool isFirst=true;
while(!q.empty()){
int sz=q.size();
int sum=0;
for(int i=1;i<=sz;i++){
int t=q.front();
q.pop();
if(t==0) ++sum;
for(int j=1;j<=p[t].sz;j++){
q.push(mp[p[t].son[j]]);
}
}
if(isFirst){
cout<<sum;
isFirst=false;
}
else cout<<" "<<sum;
}
return 0;
}