PAT 甲级 1139 First Contact (30 分)【模拟好题】

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B — quite a long shot, isn’t it? Girls would do analogously.
Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.
After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:
For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.
If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.
The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

题目大意:
A喜欢B但是A不能直接接触B,A要找到A的朋友C,C要找到B和C的朋友D做个媒。(C认识AD,D认识BC)
如果A、B异性,则A、C同性别,B、D同性别
如果A、B同性(???),则ABCD同性。

给出友好网络
对于每对询问的A,B 找到他们的媒C、D
首先输出媒的对数
之后按照升序输出每一对

分析
先找A的所有同性朋友C,再找B的所有同性朋友D,当C和D两人是朋友的时候则可以输出C和D

神坑
有数据为0000-0000,如果用int存人的信息则一定会错误,必须用string
输出贯彻了PAT一贯的风格:用cout会超时

#include <bits/stdc++.h>
using namespace std;
unordered_map<string, bool> g;  // 性别,true为1,false为0
vector<string> v[10000];  // v[xxxx]为xxxx所有的同性朋友
struct pair_hash {
    inline size_t operator()(const pair<string,string> & v) const {
        return abs(stoi(v.first))*10+abs(stoi(v.second));
    }
};
unordered_set<pair<string, string>, pair_hash> isFriend;
set <pair<string, string> > ans;

// 先找A的所有同性朋友C,再找B的所有同性朋友D,
// 当C和D两人是朋友的时候则可以输出C和D
void find(string a, string b)
{
    ans.clear();
    for (auto c : v[stoi(a)])
    {
        if (c==b) continue;
        for (auto d : v[stoi(b)])
        {
            if (d==a) continue;

            if (isFriend.count({c, d}))
                ans.insert({c, d});
        }
    }
}

int main()
{
    int n, m;
    cin >> n >> m;
    while (m --)
    {
        string a, b;
        cin >> a >> b;
        if (a[0]=='-')
        {
            g[a] = 0;
            a = a.substr(1,4);
        }
        else g[a] = 1;
        if (b[0]=='-')
        {
            g[b] = 0;
            b = b.substr(1,4);
        }
        else g[b] = 1;
        isFriend.insert({a, b});
        isFriend.insert({b, a});
        if (g[a] == g[b])
        {
            v[stoi(a)].push_back(b);
            v[stoi(b)].push_back(a);
        }
    }

    int k;
    cin >> k;
    while (k--)
    {
        string a, b;
        cin >> a >> b;
        if (a[0]=='-') a = a.substr(1, 4);
        if (b[0]=='-') b = b.substr(1, 4);
        find(a, b);
        printf("%d\n", (int)ans.size());
        for (auto x : ans)
            printf("%s %s\n", x.first.c_str(), x.second.c_str());
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值