HDU 1754 - I Hate It (线段树 单点更新)

49 篇文章 0 订阅
11 篇文章 0 订阅

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35498    Accepted Submission(s): 13983


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
  
  
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 

Author
linle
 

Source
 

Recommend
lcy


#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define REP(i, n) for(int (i)=0; (i)<n; (i)++)
#define REP1(i, n) for(int (i)=1; (i)<=(n); (i)++)
#define FOR(i, s, t) for(int (i)=(s); (i)<=(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 200000 + 20;
const int maxo = maxn * 4;

int maxv[maxo];

void pushUp(int o) {
    maxv[o] = max(maxv[o<<1], maxv[o<<1|1]);
}

void update(int o, int L, int R, int x, int score) {
    if(L == x && R == x) {
        maxv[o] = score;
        return ;
    }
    int M = L + (R-L) / 2;
    if(x <= M) update(o<<1, L, M, x, score);
    else update(o<<1|1, M+1, R, x, score);
    pushUp(o);
}

int ql, qr, qv;
void query(int o, int L, int R) {
    if(ql <= L && R <= qr) {
        qv = max(qv, maxv[o]);
        return ;
    }
    int M = L + (R-L) / 2;
    if(ql <= M) query(o<<1, L, M);
    if(M < qr) query(o<<1|1, M+1, R);
}

void build(int o, int L, int R) {
    if(L == R) {
        scanf("%d", &maxv[o]);
        return ;
    }
    int M = L + (R-L) / 2;
    build(o<<1, L, M);
    build(o<<1|1, M+1, R);
    pushUp(o);
}

int main() {
    int n, m;

    while(scanf("%d%d", &n, &m) != EOF) {
        build(1, 1, n);
        for(int i=0; i<m; i++) {
            char c = getchar();
            while(c != 'U' && c != 'Q') c = getchar();
            int a, b;
            scanf("%d%d", &a, &b);
            if(c == 'U') {
                update(1, 1, n, a, b);
            } else {
                ql = a, qr = b, qv = -INF;
                query(1, 1, n);
                printf("%d\n", qv);
            }
        }
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值