单调队列优化dp:

用数组模拟队列速度会更快一点。

一、Fence POJ - 1821:
A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct.

Being the team’s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.

Write a program that determines the total maximal income obtained by the K workers.
Input
The input contains:
Input

N K
L1 P1 S1
L2 P2 S2

LK PK SK

Semnification

N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i
Output
The output contains a single integer, the total maximal income.
Sample Input
8 4
3 2 2
3 2 3
3 3 5
1 1 7
Sample Output
17
Hint
Explanation of the sample:

the worker 1 paints the interval [1, 2];

the worker 2 paints the interval [3, 4];

the worker 3 paints the interval [5, 7];

the worker 4 does not paint any plank

题意:有N块木板从左往右排成一行,有M个工匠对这些木板分别进行粉刷,每块木板至多被粉刷一次。第 i 个工匠要么不粉刷,要么粉刷包含木板 si 的,长度不超过 li 的连续的一段木板。
每粉刷一块可以得到 pi 的报酬,求如何安排能使工匠门得到的总报酬最多。

设F(i,j)表示前 i 个工匠,粉刷前 j 块木板(可以有空着的),工匠们能获得的最大的报酬。
状态转移方程显然,在单调队列优化dp的模型中,val(i,j) 仅与 j 有关。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<map>
#include<set>
#include<deque>
#define ll long long
#define llu unsigned ll
using namespace std;
const int inf=0x3f3f3f3f;
const ll lnf=0x3f3f3f3f3f3f3f3f;
const int mod=1e9+7;
const int maxn=100100;
int n,m;
int f[110][16100];
struct node
{
   
    int si,li,pi;
}a[110];

int cal(int i,int k)
{
   
    return f[i-1][k]-a[i].pi*k;
}
bool cmp(const node &a,const node &b)
{
   
    return a.si<b.si;
}

int main(void)
{
   
    while(scanf("%d%d",&n,&m)!=EOF)
    {
   
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&a[i].li,&a[i].pi,&a[i].si);

        memset(f,0,sizeof(f));
        sort(a+1,a+m+1,cmp);

        deque<int
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值