POJ - 2279:Mr. Young‘s Picture Permutations(线性dp)

Mr. Young wishes to take a picture of his class. The students will stand in rows with each row no longer than the row behind it and the left ends of the rows aligned. For instance, 12 students could be arranged in rows (from back to front) of 5, 3, 3 and 1 students.
X X X X X

X X X

X X X

X

In addition, Mr. Young wants the students in each row arranged so that heights decrease from left to right. Also, student heights should decrease from the back to the front. Thinking about it, Mr. Young sees that for the 12-student example, there are at least two ways to arrange the students (with 1 as the tallest etc.):
1 2 3 4 5 1 5 8 11 12

6 7 8 2 6 9

9 10 11 3 7 10

12 4

Mr. Young wonders how many different arrangements of the students there might be for a given arrangement of rows. He tries counting by hand starting with rows of 3, 2 and 1 and counts 16 arrangements:
123 123 124 124 125 125 126 126 134 134 135 135 136 136 145 146

45 46 35 36 34 36 34 35 25 26 24 26 24 25 26 25

6 5 6 5 6 4 5 4 6 5 6 4 5 4 3 3

Mr. Young sees that counting by hand is not going to be very effective for any reasonable number of students so he asks you to help out by writing a computer program to determine the number of different arrangements of students for a given set of rows.
Input
The input for each problem instance will consist of two lines. The first line gives the number of rows, k, as a decimal integer. The second line contains the lengths of the rows from back to front (n1, n2,…, nk) as decimal integers separated by a single space. The problem set ends with a line with a row count of 0. There will never be more than 5 rows and the total number of students, N, (sum of the row lengths) will be at most 30.
Output
The output for each problem instance shall be the number of arrangements of the N students into the given rows so that the heights decrease along each row from left to right and along each column from back to front as a decimal integer. (Assume all heights are distinct.) The result of each problem instance should be on a separate line. The input data will be chosen so that the result will always fit in an unsigned 32 bit integer.
Sample Input
1
30
5
1 1 1 1 1
3
3 2 1
4
5 3 3 1
5
6 5 4 3 2
2
15 15
0
Sample Output
1
1
16
4158
141892608
9694845

题目大意:
给出不超过5的k,有k行学生,当前行人数不超过后一行,每行学生有 ni 个,其中这些学生身高各不相同。
要求每一排从左到右身高递减,每一列从后到前身高递减。
设F[a1][a2][a3][a4][a5]表示各排从左边分别站了a1,a2,a3,a4,a5人时的方案数。
则可得转移方程。
其中我们可以发现,设计动态规划的转移方程,不一定要以如何计算出一个状态的形式给出,也可以考虑
一个已知状态可以更新哪些后续阶段的未知状态。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#define ll long long
using namespace std;
const int maxn=31;

int a[maxn];
int main(void)
{
    int n;
    while(scanf("%d",&n),n)
    {

        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        ll dp[a[1]+1][a[2]+1][a[3]+1][a[4]+1][a[5]+1];
        memset(dp,0,sizeof(dp));

        dp[0][0][0][0][0]=1;
        for(int i=0;i<=a[1];i++)
        {
            for(int j=0;j<=a[2];j++)
            {
                for(int k=0;k<=a[3];k++)
                {
                    for(int l=0;l<=a[4];l++)
                    {
                        for(int m=0;m<=a[5];m++)
                        {
                            if(i<a[1]) dp[i+1][j][k][l][m]+=dp[i][j][k][l][m];
                            if(j<a[2]&&j<i) dp[i][j+1][k][l][m]+=dp[i][j][k][l][m];
                            if(k<a[3]&&k<i&&k<j) dp[i][j][k+1][l][m]+=dp[i][j][k][l][m];
                            if(l<a[4]&&l<i&&l<j&&l<k) dp[i][j][k][l+1][m]+=dp[i][j][k][l][m];
                            if(m<a[5]&&m<i&&m<j&&m<k&&m<l) dp[i][j][k][l][m+1]+=dp[i][j][k][l][m];
                        }
                    }
                }
            }
        }

        printf("%lld\n",dp[a[1]][a[2]][a[3]][a[4]][a[5]]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值