锐捷复习笔记-MPLS VPN Option C 1

hostname R1

interface GigabitEthernet 0/0

 no switchport

 ip address 12.0.0.1 255.255.255.0

 ip ospf 1 area 0

interface Loopback 0

 ip address 1.1.1.1 255.255.255.255

 ip ospf 1 area 0

router ospf 1

 graceful-restart

hostname R2

ip vrf 1

 rd 1:100

 route-target export 200:100

 route-target import 100:200

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip vrf forwarding 1

 ip address 12.0.0.2 255.255.255.0

 ip ospf 1 area 0

interface GigabitEthernet 0/1

 no switchport

 ip address 23.0.0.2 255.255.255.0

 ip ospf 100 area 0

 mpls ip

 label-switching

interface Loopback 0

 ip address 2.2.2.2 255.255.255.255

 ip ospf 100 area 0

router bgp 100

 bgp log-neighbor-changes

 bgp graceful-restart restart-time 120

 bgp graceful-restart stalepath-time 360

 bgp graceful-restart

 neighbor 7.7.7.7 remote-as 200

 neighbor 7.7.7.7 ebgp-multihop 255

 neighbor 7.7.7.7 update-source Loopback 0

 address-family ipv4

  no neighbor 7.7.7.7 activate

  exit-address-family

 address-family vpnv4 unicast

  neighbor 7.7.7.7 activate

  neighbor 7.7.7.7 send-community extended

  exit-address-family

 

 address-family ipv4 vrf 1

  redistribute ospf 1

  exit-address-family

router ospf 1 vrf 1

 graceful-restart

 redistribute bgp subnets

router ospf 100

 graceful-restart

mpls router ldp

 ldp router-id interface Loopback 0

 graceful-restart

hostname R3

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip address 23.0.0.3 255.255.255.0

 ip ospf 100 area 0

 mpls ip

 label-switching

interface GigabitEthernet 0/1

 no switchport

 ip address 34.0.0.3 255.255.255.0

 ip ospf 100 area 0

 mpls ip

 label-switching

interface Loopback 0

 ip address 3.3.3.3 255.255.255.255

 ip ospf 100 area 0

router ospf 100

 graceful-restart

mpls router ldp

 ldp router-id interface Loopback 0

 graceful-restart

hostname R4

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip address 34.0.0.4 255.255.255.0

 ip ospf 100 area 0

 mpls ip

 label-switching

interface GigabitEthernet 0/1

 no switchport

 ip address 45.0.0.4 255.255.255.0

 label-switching

interface Loopback 0

 ip address 4.4.4.4 255.255.255.255

 ip ospf 100 area 0

router bgp 100

 bgp log-neighbor-changes

 bgp graceful-restart restart-time 120

 bgp graceful-restart stalepath-time 360

 bgp graceful-restart

 neighbor 45.0.0.5 remote-as 200

 address-family ipv4

  redistribute ospf 100

  neighbor 45.0.0.5 activate

  neighbor 45.0.0.5 send-label

  exit-address-family

router ospf 100

 graceful-restart

 redistribute bgp subnets

mpls router ldp

 ldp router-id interface Loopback 0

 advertise-labels for bgp-routes

 graceful-restart

hostname R5

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip address 45.0.0.5 255.255.255.0

 label-switching

interface GigabitEthernet 0/1

 no switchport

 ip address 56.0.0.5 255.255.255.0

 ip router isis 200

 mpls ip

 label-switching

interface Loopback 0

 ip address 5.5.5.5 255.255.255.255

 ip router isis 200

router bgp 200

 bgp log-neighbor-changes

 bgp graceful-restart restart-time 120

 bgp graceful-restart stalepath-time 360

 bgp graceful-restart

 neighbor 45.0.0.4 remote-as 100

 address-family ipv4

  redistribute isis 200 level-1-2

  neighbor 45.0.0.4 activate

  neighbor 45.0.0.4 send-label

  exit-address-family

router isis 200

 net 49.0050.0500.5005.00

 redistribute bgp

 graceful-restart

mpls router ldp

 ldp router-id interface Loopback 0

 advertise-labels for bgp-routes

 graceful-restart

hostname R6

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip address 56.0.0.6 255.255.255.0

 ip router isis 200

 mpls ip

 label-switching

interface GigabitEthernet 0/1

 no switchport

 ip address 67.0.0.6 255.255.255.0

 ip router isis 200

 mpls ip

 label-switching

interface Loopback 0

 ip address 6.6.6.6 255.255.255.255

 ip router isis 200

router isis 200

 net 49.0060.0600.6006.00

 graceful-restart

mpls router ldp

 ldp router-id interface Loopback 0

 graceful-restart

hostname R7

ip vrf 1

 rd 200:8

 route-target export 100:200

 route-target import 200:100

mpls ip

interface GigabitEthernet 0/0

 no switchport

 ip address 67.0.0.7 255.255.255.0

 ip router isis 200

 mpls ip

 label-switching

interface GigabitEthernet 0/1

 no switchport

 ip vrf forwarding 1

 ip address 78.0.0.7 255.255.255.0

 ip router isis 1

interface Loopback 0

 ip address 7.7.7.7 255.255.255.255

 ip router isis 200

router bgp 200

 bgp log-neighbor-changes

 bgp graceful-restart restart-time 120

 bgp graceful-restart stalepath-time 360

 bgp graceful-restart

 neighbor 2.2.2.2 remote-as 100

 neighbor 2.2.2.2 ebgp-multihop 255

 neighbor 2.2.2.2 update-source Loopback 0

 address-family ipv4

  no neighbor 2.2.2.2 activate

  exit-address-family

 address-family vpnv4 unicast

  neighbor 2.2.2.2 activate

  neighbor 2.2.2.2 send-community extended

  exit-address-family

 

 address-family ipv4 vrf 1

  redistribute isis 1

  exit-address-family

router isis 1

 is-type level-2-only

 vrf 1

 net 49.0001.0070.0700.7007.00

 redistribute bgp

 graceful-restart

router isis 200

 net 49.0070.0700.7007.00

 graceful-restart

mpls router ldp

 ldp router-id interface Loopback 0

 graceful-restart

hostname R8

interface GigabitEthernet 0/0

 no switchport

 ip address 78.0.0.8 255.255.255.0

 ip router isis 1

interface Loopback 0

 ip address 8.8.8.8 255.255.255.255

 ip router isis 1

router isis 1

 net 49.0001.0080.0800.8008.00

 graceful-restart

  • 14
    点赞
  • 19
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

学网络不如种地

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值