POJ1068 STL解法思考

以下是对f_zyj大佬模板中提供的利用string和stack模拟过程的学习和注解

f_zyj大佬的博客:

http://blog.csdn.net/f_zyj/article/details/51594851

地址为pdf中第14页


Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001


#define pause system("pause");
#define fence puts("-------------");
#define endline puts("")
/*
好久没读英文题了,边查边看好无奈..
意思大概是给一串括号
这个括号根据他的规则有两种表示形式
要求 输入第一种 输出第二种
p[i]表示括号字符串中每个')'前面有多少个'('
w[i]表示括号字符串中每个')'匹配'('成功时,
匹配到的'('到')'之间成功匹配的对数,自身算一个
如(((()()())))
中间三个是1,因为他们中间没有成功()对
往外一层一层加一
所以是1 1 1 4 5 6
//这里看题意看了好久
题目规模很小,所以大佬用了 string 和 stack 模拟
*/
#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main()
{
	int n;
	cin >> n;
	for (int i = 0; i<n; i++)
	{
		int m;
		cin >> m;
		string str;
		int leftpa = 0;//辅助记录当前'('的个数
		for (int j = 0; j<m; j++)  // 读入P编码,构造括号字符串
		{
			int p;
			cin >> p;
			for (int k = 0; k<p - leftpa; k++) str += '(';
			str += ')';//每一次循环加一个')'
			leftpa = p;
		}
		stack<int> s;
		for (string::iterator it = str.begin(); it != str.end(); it++)
		{   // 构造M编码
			//我对栈结构的理解很浅啊,这么简单的用法都看了半天,需要加强练习!.
			if (*it == '(')
				s.push(1);//待匹配
			else
			{
				int p = s.top(); s.pop();//遇到')'开始计算,取出一个用于匹配,那么他前一个就是现在的top就加上了这一个,表示从这个左括号开始有一个成对的括号了.
				cout << p << " ";
				if (!s.empty()) s.top() += p;//同理,取出的那个元素的值是多少,就有多少对
			}
		}
		cout << endl;
	}
	pause
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值