并查集模板题 HDU1325 Is It A Tree?


Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24214    Accepted Submission(s): 5543



Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


这里写图片描述
图中入度未标出,请去原题查看


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.


 


Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

 


Output

For each test case display the line Case k is a tree." or the lineCase k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

 


Sample Input

   
   
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

 


Sample Output

   
   
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

 


Source


 


题解:
同前面一题,这题加上 对树的判断:节点入度<=1
输入小于0的数退出


#include<bits/stdc++.h>
using namespace std;
//盲打一遍,权当熟练一下了
//并查集结构
const int maxn=100000;
int F[maxn];
int in[maxn];

int f(int x)
{
    if(x==F[x])
        return x;
    return F[x]=f(F[x]);
}

void Union(int x,int y)
{
    x=f(x);
    y=f(y);
    if(x!=y)
        F[x]=y;
    else
        F[y]=x;
}

inline bool same(int x,int y)
{
    return f(x)==f(y);
}

void ini(int n)
{
    for(int i=1;i<=n;++i)
    {
        F[i]=i;
    }
    memset(in,0,sizeof(in));
}

int main()
{
    int n,m;
    int t=1;
    while(scanf("%d %d",&n,&m),n>=0&&m>=0)
    {
        ini(maxn);
        set<int>st;
        bool flag=1;
        while(n||m)
        {
            if(same(n,m))
                flag=0;
            st.insert(n);
            st.insert(m);
            ++in[m];
            Union(n,m);
            scanf("%d %d",&n,&m);
        }
        if(!flag)
            printf("Case %d is not a tree.\n",t);
        else
        {
            int cnt=0;
            set<int>::iterator it=st.begin();
            for(;it!=st.end();++it)
            {
                if(f(*it)==*it)
                    ++cnt;
                if(in[*it]>1)// 判 断 入 度
                    cnt=2;
            }
            if(cnt>1)
                printf("Case %d is not a tree.\n",t);
            else
                printf("Case %d is a tree.\n",t);
        }
        ++t;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值