数据结构上机测试2-1:单链表操作A

数据结构上机测试2-1:单链表操作A

Time Limit: 1000ms   Memory limit: 4096K  有疑问?点这里^_^

题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

输入

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

输出

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

示例输入

10
56 25 12 33 66 54 7 12 33 12
12

示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33
这道题就是顺序建链表并且删除相同的元素。但是应当注意第一个和最后一个的删除。
#include<stdio.h>
#include<iostream>
using namespace std;
int n;
struct node
{
    int  d;
    node *next;
};

node *CreatList(int n)      //顺序建表
{
    node *head=new node;
    head->next=NULL;
    node *tail=head;
    for(int i=0;i<n;i++)
    {
        node *p=new node ;
        cin>>p->d;
        tail->next=p;
        tail=p;
    }
    tail->next=NULL;
    return head;
}
node *DeleteList(node *head,int m)  //删除相同元素
{
    node *p=head;
    node *q=p->next;
    while(q!=NULL)
    {
        if(q->d==m)
            {
                p->next=q->next;
                delete q;
                n--;
            }
        else
            p=p->next;
        q=p->next;

    }
    return head;
}

void PrintList(node *head)
{
    node *p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            cout<<p->d<<endl;
        else
            cout<<p->d<<" ";
        p=p->next;
    }
}
int main()
{
    cin>>n;
    node *head=NULL;
    head=CreatList(n);
    int m;
    cin>>m;
    cout<<n<<endl;
    PrintList(head);
    head=DeleteList(head,m);
    cout<<n<<endl;
    PrintList(head);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值