数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

提示

不得使用数组。

思路:就是先顺序建表,在逆序建表。

#include<stdio.h>
#include<iostream>
using namespace std;

struct node
{
    int  d;
    node *next;
};
node *CreatList(node *head)      //顺序建表
{
    head=new node;
    head->next=NULL;
    node *tail=head;
    while(true)
    {
        node *p=new node ;
        cin>>p->d;
        if(p->d==-1)
            break;
        tail->next=p;
        tail=p;
    }
    tail->next=NULL;
    return head;
}
node *InvertList(node *head)      //逆置链表
{
    node *p=head->next;
    head->next=NULL;
    while(p!=NULL)
    {
        node * q=p;
        p=p->next;                 //注意p=p->next不能放到后面
        q->next=head->next;
        head->next=q;
    }
    return head;
}
void PrintList(node *head)  //输出链表
{
    node *p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            cout<<p->d<<endl;
        else
            cout<<p->d<<" ";
        p=p->next;
    }
}
int main()
{
    node *head=NULL;
    head=CreatList(head);
    head=InvertList(head);
    PrintList(head);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值