数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

提示

不得使用数组!

#include<stdio.h>
#include<iostream>
using namespace std;
struct node
{
    int  d;
    node *next;
};
node *CreatList(int n)      //顺序建表
{
    node *head=new node;
    head->next=NULL;
    node *tail=head;
    for(int i=0;i<n;i++)
    {
        node *p=new node ;
        cin>>p->d;
        tail->next=p;
        tail=p;
    }
    tail->next=NULL;
    return head;
}

void PrintList(node *head)      //输出链表
{
    node *p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            cout<<p->d<<endl;
        else
            cout<<p->d<<" ";
        p=p->next;
    }
}
node *SplitList(node *h1)       //拆分链表
{
    int n=0,m=0;
    node *h2=new node;
    h2->next=NULL;
    node *p=h1->next;
    h1->next=NULL;
    node *tail2=h2;
    node *tail1=h1;
    while(p!=NULL)
    {
        if(p->d%2)
            {
                tail1->next=p;
                tail1=p;
                n++;
            }
        else
            {
                tail2->next=p;
                tail2=p;
                m++;
            }
        p=p->next;
    }
    tail1->next=NULL;<span style="white-space:pre">		</span>//注意别忘了
    tail2->next=NULL;
    cout<<m<<" "<<n<<endl;
    PrintList(h2);
    PrintList(h1);
}


int main()
{
    int n;
    cin>>n;
    node *head=NULL;
    head=CreatList(n);
    SplitList(head);
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值