VS 2010调用Matalab R2010b生成的DLL库的配置问题



可以在http://cn.mathworks.com/matlabcentral/index.html?s_cid=pl_mlc下载到Matalab Compiler Runtime和Matalab R2010b,Matalab R2010b生成相应的DLL文件,这里不详细说明.

当前目标框架为.net frame 2,在安装.net frame4的基础上,为了避免出现当前运行时为 .net frame 4和当前所需运行时为.net frame 4不同步的错误,这里我们需要通过对应用程序配置文件进行更改

<?xml version="1.0"?>
<configuration>

  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" sku = ".NETFramework,Version=v4.0"/>
    <supportedRuntime version="v2.0.50727"/>
  </startup>
</configuration>

从上面可以看出,它所支持的运行时为两个版本,上面的useLeagacyV2RuntimeActionPolicy为true,但是在调好后仍然出现错误,于是就在添加的引用中将一些低版本的DLL删除即可,这里的版本不是DLL的运行时版本,但是当我再次打开,并将之前删除的DLL重新饮用后,发现又能运行了,就不明白了,之前在网上找的基本修改(修改目标框架后,会自动生成app.config文件)app.config文件后就可以了,看来是正确的,不知道为什么。

记录一下,以后留用

©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页