hud 2602 Bone Collector(0-1背包问题的解法和优化)

Bone Collector
http://acm.hdu.edu.cn/showproblem.php?pid=2602
 

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
 
 
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

14

 二维dp,记忆化回溯

#include<bits/stdc++.h>
using namespace std;
const int N = 1011;
int w[N], c[N];
int dp[N][N];
int solve1(int n, int C) {
	for (int i = 1; i <= n; i++) {
		for (int j = 0; j <= C; j++) {
			if (c[i] > j) dp[i][j] = dp[i - 1][j]; // c[i]
			else dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - c[i]] + w[i]);
		}
	}
	return dp[n][C];
}
int solve(int i, int j) { // 记忆化回溯
	if (dp[i][j] != 0) return dp[i][j];
	if (i == 0) return 0;
	int res;
	if (c[i] > j) res = solve(i - 1, j);
	else res = max(solve(i - 1, j), solve(i - 1, j - c[i]) + w[i]);
	return dp[i][j] = res;
}
int main() {
	int T; cin >> T;
	while (T--) {
		int n, C;
		cin >> n >> C;
		for (int i = 1; i <= n; i++) cin >> w[i];
		for (int i = 1; i <= n; i++) cin >> c[i];
		memset(dp, 0, sizeof(dp));
		cout << solve(n, C) << endl;
	}
	return 0;
}

一维dp

#include<bits/stdc++.h>
using namespace std;
const int N = 1011;
int w[N], c[N];
int dp[N];
int solve(int n, int C) {
	int now = 0, old = 1;
	for (int i = 1; i <= n; i++) {
		for (int j = C; j >= c[i]; j--) {
			dp[j] = max(dp[j], dp[j - c[i]] + w[i]);
		}
	}
	return dp[C];
}
int main() {
	int T; cin >> T;
	while (T--) {
		int n, C;
		cin >> n >> C;
		for (int i = 1; i <= n; i++) cin >> w[i];
		for (int i = 1; i <= n; i++) cin >> c[i];
		memset(dp, 0, sizeof(dp));
		cout << solve(n, C) << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值