poj 2976 Dropping tests (0/1分数规划)

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 31958Accepted: 10375

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is 

. However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

思路:

对题意的

 进行化简,尝试找的那个x小于。

左端点为0,右端点为ai的累加和。这是用高效的二分法进行查找。

在进行二分的时候,还要考虑是否为单调性。

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct Pair {
	int a, b;
	double y;
}p[1005];
bool cmp(Pair a, Pair b) {
	return a.y > b.y; // 从大到小
}
int n, k;
bool check(double x) {
	for (int i = 0; i < n; i++) {
		p[i].y = p[i].a * 1.0 - x * p[i].b; // y = a - x*b  在x轴小点的值
	}
	sort(p, p + n, cmp);
	double f = 0;
	for (int i = 0; i < k; i++) f += p[i].y;
	return f < 0;
}
int main() {
	while (cin >> n >> k, n + k) {
		k = n - k; // 选出 k 对
		for (int i = 0; i < n; i++) cin >> p[i].a;
		for (int i = 0; i < n; i++) cin >> p[i].b;
		double L = 0, R = 0;
		for (int i = 0; i < n; i++)	R += p[i].a;
		for (int i = 0; i < 50; i++) {
			double mid = L + (R - L) / 2;
			if (check(mid)) R = mid;
			else L = mid;
		}
		printf("%d\n", (int)(100 * (L + 0.005)));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值