One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
"This supercomputer is great," remarked Chip. "I only wish Timothy were here to see these results." (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLong- Integer. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Example Input
123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
Example Output
370370367037037036703703703670
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
private static Scanner cin = new Scanner(System.in);
public static void main(String[] args) {
String [] input = new String[110];
BigInteger bigint = new BigInteger("0");
int i = 0;
do{
input[i] = cin.next();
bigint=bigint.add(new BigInteger(input[i]));
i++;
}while(!input[i-1].equals("0"));
System.out.println(bigint);
}
}
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
private static Scanner cin = new Scanner(System.in);
public static void main(String[] args) {
String [] input = new String[110];
BigInteger bigint = new BigInteger("0");
int i = 0;
do{
input[i] = cin.next();
bigint=bigint.add(new BigInteger(input[i]));
i++;
}while(!input[i-1].equals("0"));
System.out.println(bigint);
}
}