Where is the Marble? (简单题)

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

 

题目大意是找到指定数字(经过排序后的)位置,用sort()lower_bound()就可以做了,记住的是不能用upper_bound().

贴代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn = 10005;
int a[maxn],b[maxn];

bool cmp(int a,int b){
    return a < b;
}
int main()
{
    int n,q;
    int kase = 1;
    while(cin>>n>>q){
        if(n == 0 || q == 0) break;
        for(int i = 0;i < n;i++){
            cin>>a[i];
        }
        for(int i = 0;i < q;i++){
            cin>>b[i];
        }
        cout<<"CASE# "<<kase++<<":"<<endl;
        sort(a,a+n,cmp);
        for(int i = 0;i < q;i++){
            int t = lower_bound(a,a+n,b[i]) - a;
            if(a[t] == b[i]){
                cout<<b[i]<<" found at "<<t+1<<endl;
            }
            else{
                cout<<b[i]<<" not found"<<endl;
            }
        }
    }
    return 0;
}
  • 5
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值