Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3
题目大意是找到指定数字(经过排序后的)位置,用sort()和lower_bound()就可以做了,记住的是不能用upper_bound().
贴代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn = 10005;
int a[maxn],b[maxn];
bool cmp(int a,int b){
return a < b;
}
int main()
{
int n,q;
int kase = 1;
while(cin>>n>>q){
if(n == 0 || q == 0) break;
for(int i = 0;i < n;i++){
cin>>a[i];
}
for(int i = 0;i < q;i++){
cin>>b[i];
}
cout<<"CASE# "<<kase++<<":"<<endl;
sort(a,a+n,cmp);
for(int i = 0;i < q;i++){
int t = lower_bound(a,a+n,b[i]) - a;
if(a[t] == b[i]){
cout<<b[i]<<" found at "<<t+1<<endl;
}
else{
cout<<b[i]<<" not found"<<endl;
}
}
}
return 0;
}