poj2432 Anniversary party 入门级树形dp

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9147 Accepted: 5262

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意:某大学举行周年会,有些人要参加,每个人都有个活跃度,但是不能让一个人和他的直接上司同时参加,已知这些人的直接上司,求最大的活跃度。

解析:这些人之间的关系可以构成一棵树,本题是一个基础的树形dp。用rat[i][0]表示以当前结点为根的子树且不选择当前点的最大值,rat[i][1]表示以当前结点为根且选择当前结点的最大值。那么转移方程为:rat[i][0] = sum(max(rat[j][1],rat[j][0]))(j是i的孩子结点),rat[i][1] = sum(rat[j][0])+value[i]。

因为他们之间的关系是一棵树,所以树形dp基本都是按照递归进行求值,本题使用dfs进行递归。具体代码如下:

#include <stdio.h>
#include <string.h>
#include <vector>
#include <algorithm>
#define N 6005
using namespace std;

int rat[N][2], value[N], vis[N];
vector<int> V[N];

void dfs(int i){
	if(V[i].size() == 0){
		rat[i][0] = 0;
		rat[i][1] = value[i];
		return;
	}
	for(int j = 0; j < V[i].size(); j++){
		int x = V[i][j];
		dfs(x);
	}
	int sum0 = 0, sum1 = 0;
	for(int j = 0; j < V[i].size(); j++){
		int x = V[i][j];
		sum1 += rat[x][0];
		sum0 += max(rat[x][0], rat[x][1]);
	}
	rat[i][0] = sum0;
	rat[i][1] = sum1 + value[i];
}
int main(){
	int n, l, k, m;
	while(scanf("%d", &n)){
		if(n == 0){
			scanf("%d", &m);
			break;
		}
		for(int i = 1 ; i <= n; i++){
			scanf("%d", &value[i]);
			V[i].clear();
			rat[i][0] = rat[i][1] = 0;
		}
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < n-1; i++){
			scanf("%d%d", &l, &k);
			V[k].push_back(l);
			vis[l] = 1;
		}
		int root;
		for(int i = 1; i <= n; i++)
			if(!vis[i]){
				root = i;
				continue;
			}
		dfs(root);
		int ans = max(rat[root][0], rat[root][1]);
		printf("%d\n", ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值