一个数组A中存有N(N>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A0A1……AN-1)变换为(AN-M …… AN-1 A0 A1……AN-M-1)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?
输入格式:每个输入包含一个测试用例,第1行输入N ( 1<=N<=100)、M(M>=0);第2行输入N个整数,之间用空格分隔。
输出格式:在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。
输入样例:6 2 1 2 3 4 5 6输出样例:
5 6 1 2 3 4
分析:
题目虽说不允许使用另外的数组,但是我考虑到简便性还是用了...为了写这篇博客,我还是学习了其他人没有使用数组的方法,当然方法有很多,这里说一种.
这种方法可以在草稿纸上推演一下.
源代码:
#include<iostream>
using namespace std;
void reverse(int* list,int start,int last)
{
int temp;
for(int i=start,j=last;i<j;i++,j--)
{
temp=list[i];
list[i]=list[j];
list[j]=temp;
}
}
int main()
{
int N,M;
cin>>N>>M;
int* list=new int[N];
for(int i=0;i<N;i++)
cin>>list[i];
M=M%N;
reverse(list,0,N-M-1);
reverse(list,N-M,N-1);
reverse(list,0,N-1);
for(int i=0;i<N-1;i++)
cout<<list[i]<<" ";
cout<<list[N-1]<<endl;
return 0;
}