1046 Shortest Distance (20分) (含测试点2分析)

1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10 ^​5​​ ]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​ , where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10 ^​4​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 ^​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

测试点2问题:如果每次给两个点时都遍历一遍计算两点之间的距离,这种情况复杂度过高会导致TLE,因此针对这种情况可以用前缀和,先预处理距离和,再通过前缀和公式计算距离可以将时间复杂度有效降低

#include<iostream>
#include<algorithm>

using namespace std;

int n,t;
int sum;
int l[100010];  //保存题目给的距离的数组
int PrefixSum[100010]; //前缀和数组
int main() 
{
    cin >> n;
    for(int i=1;i<=n;i++)
    {
        cin >> l[i];
        sum+=l[i]; //计算整个环的总距离
    }
    for(int i=1;i<=n;i++)
        PrefixSum[i]=PrefixSum[i-1]+l[i];  //前缀和处理
    cin >> t;
    for(int i=0;i<t;i++)
    {
        if(i!=0)
            printf("\n");
        int x,y;
        cin >> x >> y;
        if(x>y)
            swap(x,y);
        int res=PrefixSum[y-1]-PrefixSum[x-1];
        if(res>sum-res)
            res=sum-res;
        printf("%d",res);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值