1144 The Missing Number (20分)
Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10 ^5 ). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.
Output Specification:
Print in a line the smallest positive integer that is missing from the input list.
Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7
本题思路:一开始置ans为1,每次都把正数存入set,如果发现此时的数与ans相同,则说明ans需要递增,递增至不在set中的最小值
#include<iostream>
#include<set>
using namespace std;
set<int> list;
int n,t,ans=1;
int main()
{
cin >> n;
for(int i=0;i<n;i++)
{
cin >> t;
list.insert(t);
if(t==ans)
while(list.find(ans)!=list.end())
ans++;
}
printf("%d",ans);
return 0;
}