2015多校联合第六场 hdu5360hiking

Problem Description
There are  n  soda conveniently labeled by  1,2,,n . beta, their best friends, wants to invite some soda to go hiking. The  i -th soda will go hiking if the total number of soda that go hiking except him is no less than  li  and no larger than  ri . beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li  and no larger than  ri , otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n105) , the number of soda. The second line constains  n  integers  l1,l2,,ln . The third line constains  n  integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n  denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
  
  
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8

是的 这道题我又没读明白题意orz 你六级是怎么过的呢->_-> 题意是说 :给的两行数是邀请第i人时已有人数的下限和上限 求总共能邀请到多少人以及邀请的顺序 是逐个邀请的哟~

看题意时用结构体排序完觉得完事大吉 真是图样图森破 经过贪心的策略 本题解法如下:结构体还是要有排序滴~

大循环的目的是每次多确定邀请的某个人 开头需要判断当我邀请了t个人时有哪些人的下限可以满足条件 满足?压入队列  对于队列中的人再判断是否队首元素的上限满足当前人数 不满足?压入vector (为啥不满足还压入呢? 因为他拒绝了啊 所以不占人数的)此时 队列为空 结束循环 队列不空 邀请一个 

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
int t,n;
struct node
{
    int l,r,num;
    bool operator<(const node &rhs)const{return r>rhs.r;}
}s[100005];
bool cmp(node a,node b)
{
    if(a.l==b.l) return a.r<b.r;
    return a.l<b.l;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&s[i].l),s[i].num=i+1;
        for(int i=0;i<n;i++) scanf("%d",&s[i].r);
        priority_queue<node,vector<node> >q;
        vector<int>ans;
        sort(s,s+n,cmp);
        int t=0,cur=0;
        for(;;t++)
        {
            while(cur<n&&s[cur].l<=t)
            {
                q.push(s[cur]);
                cur++;
            }
            while(!q.empty()&&q.top().r<t)
            {
                ans.push_back(q.top().num);
                q.pop();
            }
            if(q.size()==0) break;
            else
            {
                ans.push_back(q.top().num);
                q.pop();
            }
        }
        printf("%d\n",t);
        while(cur<n)
        {
            ans.push_back(s[cur].num);
            cur++;
        }
        //printf("%d",ans[0]);
        for(int i=0;i<ans.size();i++) printf("%d ",ans[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值