2015多校联合第六场hdu5375Gray code

Description

The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems. 



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai. 
Can you tell me how many points you can get at most? 

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4. 
 

Input

The first line of the input contains the number of test cases T. 

Each test case begins with string with ‘0’,’1’ and ‘?’. 

The next line contains n (1<=n<=200000) integers (n is the length of the string). 

a1 a2 a3 … an (1<=ai<=1000) 
 

Output

For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input

    
    
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output

    
    
Case #1: 12 Case #2: 15

这又是一个看半天题没看懂什么意思的神题(⊙﹏⊙)b 查阅了二进制格雷码(Binary Gray Code是什么鬼之后,知道了是dp仍写不出来,惭愧啊T^T

看完题解感觉跟之前什么铺瓷砖的结构差不多 好久好久没做dp了 代码确实简单

这个题还有一个梗 :→_→  二进制码转换为格雷码的公式为将二进制码右移一位然后与原来的二进制码按位异或

即当前位是0 之前是1或者当前位是1 之前0  那么dp值+a[i]  其实再努力想一想也能想出来了吧

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 200004
using namespace std;
int t,dp[maxn][2],a[maxn];
char str[maxn];
int main()
{
  //  freopen("cin.txt","r",stdin);
    while(~scanf("%d",&t))
    {
        int cas=1;
        while(t--)
        {

            scanf("%s",str);
            memset(dp,-0x3f3f3f3f,sizeof(dp));
            int len=strlen(str);
            for(int i=0;i<len;i++)scanf("%d",&a[i]);
            if(str[0]=='0'||str[0]=='?') dp[0][0]=0;
            if(str[0]=='1'||str[0]=='?') dp[0][1]=a[0];
            for(int i=1;i<len;i++)
            {
                if(str[i]=='0'||str[i]=='?')
                {
                    dp[i][0]=max(dp[i-1][0],dp[i-1][1]+a[i]);
                }
                if(str[i]=='1'||str[i]=='?')
                {
                    dp[i][1]=max(dp[i-1][1],dp[i-1][0]+a[i]);
                }
            }
            printf("Case #%d: %d\n",cas++,max(dp[len-1][0],dp[len-1][1]));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值