poj2127Greatest Common Increasing Subsequence【LICS】

Description

You are given two sequences of integer numbers. Write a program to determine their common increasing subsequence of maximal possible length.
Sequence S 1 , S 2 , . . . , S N of length N is called an increasing subsequence of a sequence A 1 , A 2 , . . . , A M of length M if there exist 1 <= i 1 < i 2 < . . . < i N <= M such that S j = A ij for all 1 <= j <= N , and S j < S j+1 for all 1 <= j < N .

Input

Each sequence is described with M --- its length (1 <= M <= 500) and M integer numbers A i (-2 31 <= A i < 2 31 ) --- the sequence itself.

Output

On the first line of the output file print L --- the length of the greatest common increasing subsequence of both sequences. On the second line print the subsequence itself. If there are several possible answers, output any of them.

Sample Input

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2
1 4

Source

Northeastern Europe 2003, Northern Subregion

裸的LICS加上输出路径就把自己搞懵了;_; 一心想着记录父节点可以递归输出,然而远不用那么麻烦,最长递增公共子序列嘛==而且是二维的(废话),多加一个二维数组记录哈希了的前一个对应坐标,根据这个坐标记录每步的走法,这么说来,我原来递归的写法就只差一个数组呗,等回头补上

/*********
poj2127
2016.2.12
1168K	141MS	C++	1188B
*********/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,x[505],y[505],dp[505],pos[505][505],ans[505];
void solve()
{
    memset(dp,0,sizeof(dp));
    memset(pos,0,sizeof(pos));
    for(int i=1;i<=n;i++)
    {
        int tmp=0;
        memcpy(pos[i],pos[i-1],sizeof(pos[0]));///
        for(int j=1;j<=m;j++)
        {
            if(x[i]>y[j]&&dp[j]>dp[tmp]) tmp=j;
            if(x[i]==y[j]&&dp[tmp]+1>dp[j])
            {
                dp[j]=dp[tmp]+1;
                pos[i][j]=i*(m+1)+tmp;
            }
        }
    }
    int maxn=0;
    for(int i=1;i<=m;i++) if(dp[maxn]<dp[i]) maxn=i;
    int i=m*n+n+maxn;
    for(int j=dp[maxn];j>0;j--)
    {
        ans[j]=y[i%(m+1)];
        i=pos[i/(m+1)][i%(m+1)];
    }
    printf("%d\n",dp[maxn]);
    for(i=1;i<=dp[maxn];i++)
    {
        if(i!=1) printf(" %d",ans[i]);
        else printf("%d",ans[i]);
    } puts("");
}
int main()
{
   // freopen("cin.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++) scanf("%d",&x[i]);
        scanf("%d",&m);
        for(int i=1;i<=m;i++) scanf("%d",&y[i]);
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值