hdu3555Bomb【数位dp入门题】

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 12286    Accepted Submission(s): 4410


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
发现dp题多数是签到题啊==

貌似数位dp暂时发现了两种题型,本质还是一种没错==之前的n进制是需要把原数字转化成n叉数,截取自己需要的部分。

这次说的题是针对这个数字本身来说的,也可以认为是一个十进制,就是一个10叉树,我怎么这么机智==用递推解释就是把一个树杈接到当前节点后面形成新的树杈。以这个题为例,dp[i][0]   dp[i][1]   dp[i][2]分别表示i长度下:不存在不吉利数字;不存在不吉利数字开头是9;存在不吉利数字。首先预处理三个数组,然后就简单啦

主要还是不要62那个题没学明白,用的不是标准的数位dp导致的

/*************
hdu3555
2016.3.11
15MS	1736K	1525 B	C++
**************/
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
long long dp[22][3];
/*
 * dp[i][0],表示长度为i,不存在不吉利数字
 * dp[i][1],表示长度为i,不存在不吉利数字,且最高位为2
 * dp[i][2],表示长度为i,存在不吉利数字
 */
void init()
{
    dp[0][0]=1;dp[0][1]=0;dp[0][2]=0;
    for(int i=1;i<=20;i++)
    {
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1];//在最高位加上除4以外的9个数字,但要减掉2之前加上6
        dp[i][1]=dp[i-1][0];//在不含不吉利数字的最高位加上2
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];
        //在已有不吉利数字前加任意数字,或者无不吉利数字的最高位加4,或者在2前面加6
    }
}
int bit[22];
long long solve(long long n)
{
    int len=0;
    long long tmp=n;
    while(n)
    {
        bit[++len]=n%10;
        n/=10;
    }
    bit[len+1]=0;
    long long ans=0;
    bool flag=false;
    for(int i=len;i>=1;i--)
    {
        ans+=dp[i-1][2]*bit[i];
        if(flag)//高位已经出现49,后面随意
            ans+=dp[i-1][0]*bit[i];
        if(!flag&&bit[i]>4)
            ans+=dp[i-1][1];
        if(bit[i+1]==4&&bit[i]==9)
            flag=true;
    }
    if(flag)ans++;//这个数本身
    return ans;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    init();
    long long n;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        printf("%I64d\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值