poj3252Round Numbers【数位dp】

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11258 Accepted: 4205

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source


这个题是刚刚那个的加强版,比较绝的是,根本看不出二者有什么关系嘛

要求一定范围内,二进制下“1”的个数比"0"的个数小的情况数,怎么想怎么像哈理工的校赛,喂喂,不能因为都是二进制的1个数就非得张冠李戴啊==尽量往上一个题hdu3709上靠,两个题的第一维都可以是长度,而既然要求0的个数比1的个数多,那么第二、三维就分别是0的个数和1的个数,先别急着说为啥在遍历的过程中长度若是已知,除了0不就是1嘛。我们的第一个参数应该说它不是长度,而是应该认为是最高位是哪一位。这时候头脑中联想那个论文的配图:原来是一个满二叉树,由于已知数字的原因,需要减下去一部分@。@

再说另外两个参数 ,flag和前文的一样,z不好理解,是用来确定首位1的放置,就是在限制长度!

416K16MSC++

/*************
poj3252
2016.3.11**********/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[40][40][40],num[40];
int dfs(int pos,int num0,int num1,bool flag,bool z)
{
    if(pos==-1) return num0>=num1;
    if(!flag&&dp[pos][num0][num1]!=-1) return dp[pos][num0][num1];
    int maxn=flag?num[pos]:1;
    int ans=0;
    for(int i=0;i<=maxn;i++)
        ans+=dfs(pos-1,(z&&i==0)?0:num0+(i==0),(z&&i==0)?0:num1+(i==1),flag&&i==maxn,z&&i==0);
    if(!flag) dp[pos][num0][num1]=ans;
    return ans;
}
int cal(int x)
{
    int pos=0;
    while(x)
    {
        num[pos++]=x%2;
        x/=2;
    }
    return dfs(pos-1,0,0,1,1);
}
int main()
{
    int n,m;
    memset(dp,-1,sizeof(dp));
    while(~scanf("%d%d",&n,&m))
    {
        printf("%d\n",cal(m)-cal(n-1));
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值