hdu3033I love sneakers!【分组背包】每组至少取一个

Total Submission(s): 4877    Accepted Submission(s): 2001


Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 

Sample Input
  
  
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output
  
  
255
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2955  2602  1561  1203  3449 
 

就比之前的题变形了这么一点点就不会啦~总记得貌似之前限制“1”的题在这里 hdu3535

既然重点是如何限制每组取的至少一个,我们需要想一下背包转移的原理:每次遍历背包大小,容量减去此物品的体积,价值加上此物品的价值。而相对于现在状态的前一转移状态下标是“体积”。而事实上,我们只是由于第一重循环的遍历省去了第一维表示组别的下标。拿这道题来说,我们不能只考虑体积作为下标,由于dp的状态可以由本组的状态转移,也可以由上一组的状态转移,所以加了一维表示组别。最开始赋值为-1,第0组是0,sizeof注意是dp[0]。上一状态是-1的不选

/***********
hdu3033
2016.3.13
109MS	5888K	1185 B	G++
***********/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int u,v;
}g[15][110];
int num[15],dp[110][10005];
int n,m,k,a,b,c;
int max(int a,int b){if(a>b)return a;return b;}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            num[a]++;
            g[a][num[a]].u=b;
            g[a][num[a]].v=c;
        }
        memset(dp,-1,sizeof(dp));
        memset(dp[0],0,sizeof(dp[0]));
        for(int i=1;i<=k;i++)
        {
            for(int j=1;j<=num[i];j++)
            {
                for(int v=m;v>=g[i][j].u;v--)
                {
                    if(dp[i][v-g[i][j].u]!=-1)
                    dp[i][v]=max(dp[i][v],dp[i][v-g[i][j].u]+g[i][j].v);
                    if(dp[i-1][v-g[i][j].u]!=-1)
                    dp[i][v]=max(dp[i][v],dp[i-1][v-g[i][j].u]+g[i][j].v);
                }
            }
        }
        if(dp[k][m]==-1)printf("Impossible\n");
        else printf("%d\n",dp[k][m]);
    }
    return 0;
}

所以说,根据3535的思想,最开始直接赋值成-inf就可以了也用不着判断之前那个点是否能取到,反正就算加进去到了最后也是小于0的就不成立

优雅的代码

/***********
hdu3033
2016.3.13
93MS	5888K	1238B	G++
***********/
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    int u,v;
}g[15][110];
int num[15],dp[110][10005];
int n,m,k,a,b,c;
int max(int a,int b){if(a>b)return a;return b;}
#define inf  0x3f3f3f3f
int main()
{
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            num[a]++;
            g[a][num[a]].u=b;
            g[a][num[a]].v=c;
        }
        memset(dp,-inf,sizeof(dp));
        memset(dp[0],0,sizeof(dp[0]));
        for(int i=1;i<=k;i++)
        {
            for(int j=1;j<=num[i];j++)
            {
                for(int v=m;v>=g[i][j].u;v--)
                {
                    //if(dp[i][v-g[i][j].u]!=-1)
                    dp[i][v]=max(dp[i][v],dp[i][v-g[i][j].u]+g[i][j].v);
                    //if(dp[i-1][v-g[i][j].u]!=-1)
                    dp[i][v]=max(dp[i][v],dp[i-1][v-g[i][j].u]+g[i][j].v);
                }
            }
        }
        if(dp[k][m]<0)printf("Impossible\n");
        else printf("%d\n",dp[k][m]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值