poj2594Treasure Exploration【最小路径覆盖+floyd传递闭包】

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

看到这个题想到是最小路径覆盖了,一顿乱套模板,也想到是单向加边了,但是floyd闭包头一次听说并且使用(让我想起来JS的闭包了==)就是i->j  j->k  求得i->k

    #include<cstdio>
    #include<cstring>
    using namespace std;
    /* **************************************************************************
    //二分图匹配(匈牙利算法的DFS实现)
    //初始化:g[][]两边顶点的划分情况
    //建立g[i][j]表示i->j的有向边就可以了,是左边向右边的匹配
    //g没有边相连则初始化为0
    //uN是匹配左边的顶点数,vN是匹配右边的顶点数
    //调用:res=hungary();输出最大匹配数
    //优点:适用于稠密图,DFS找增广路,实现简洁易于理解
    //时间复杂度:O(VE)
    //***************************************************************************/
    //顶点编号从0开始的
    const int MAXN=509;
    int n;//u,v数目
    int g[MAXN][MAXN];
    int linker[MAXN];
    bool used[MAXN];
  //  int k,m,n,u,v;
    void Floyd(int N)       //求传递闭包
    {
        for(int k = 1; k <= N; ++k)
        {
            for(int i = 1; i <= N; ++i)
            {
                for(int j = 1; j <= N; ++j)
                {
                    if(i != j && g[i][k] && g[k][j])
                        g[i][j] = 1;
                }
            }
        }
    }
    bool dfs(int u)//从左边开始找增广路径
    {
        int v;
        for(v=1;v<=n;v++)//这个顶点编号从0开始,若要从1开始需要修改
          if(g[u][v]&&!used[v])
          {
              used[v]=true;
              if(linker[v]==-1||dfs(linker[v]))
              {//找增广路,反向
                  linker[v]=u;
                  return true;
              }
          }
        return false;//这个不要忘了,经常忘记这句
    }
    int hungary()
    {
        int res=0;
        int u;
        memset(linker,-1,sizeof(linker));
        for(u=1;u<=n;u++)
        {
            memset(used,0,sizeof(used));
            if(dfs(u)) res++;
        }
        return res;
    }
    //******************************************************************************/

    int main()
    {
        //freopen("cin.txt","r",stdin);
        int m;
        while(~scanf("%d%d",&n,&m))
        {
            if(n==0&&m==0) break;
         //   printf("n=%d,m=%d\n",n,m);
            if(m==0) {printf("%d\n",n);continue;}
            memset(g,0,sizeof(g));
            while(m--)
            {
                int u,v;
                scanf("%d%d",&u,&v);
                g[u][v]=1;
            }
            Floyd(n);
            printf("%d\n",n-hungary());
        }
        return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值