用一个整数去表示一个集合(hdu3006)

学习要点:将一个集合用一个整数来表示,将集合间的并运算转成按位与运算

/* 杭电http://acm.hdu.edu.cn/showproblem.php?pid=3006 
The Number of set
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 368    Accepted Submission(s): 225
Problem Description
Given you n sets.All positive integers in sets are not less than 1 and not greater 
than m.If use these sets to combinate the new set,how many different new set you can get.
The given sets can not be broken.

Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).
Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,
then k integers are given. The input is end by EOF.
Output
For each case,the output contain only one integer,the number of the different sets you get.

Sample Input
4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4
Sample Output
15
2
*/
/*2010年8月4日
**/
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n;
int m; //n为表示有n个集合,集合中的元素的值在[1,m]之间
int sets[1<<15]; //每个集合对应着一个16位的二进制数,一个二进制数转成十进制数来处理
while(cin>>n)
{
   int ans=0;
   memset(sets,0,sizeof(sets));
   cin>>m; 
   for(int i=0;i<n;i++)
   {
    int k;
    cin>>k; //当前集合有k个元素
    int x=0;
    for(int j=0;j<k;j++)
    {
     int a=0;//当前集合中的一个元素a 
     cin>>a;
     if(a>=1&&a<=m)
     {
     a--;
     x|=1<<a;   //这句代码等价于
     }
    }
    sets[x]=1; //x表示的就是一个集合,标记为1  
    for(int i=1;i<(1<<(m+1));i++)
       {
       if(sets[i]==1) //
      sets[i|x]=1;   
       }
   }
   for(int i=1;i<(1<<(m+1));i++) //
   {
    if(sets[i]==1)
     ans++;
   }
   cout<<ans<<endl;
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值