**贪心法** 之练习题集

#贪心法 之练习题集

##https://vjudge.net/contest/174166#problem/A Hero

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero’s HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
Output
Output one line for each test, indicates the minimum HP loss.
Sample Input
1
10 2
2
100 1
1 100
Sample Output
20
201

这题是一道典型的贪心题,我们首先会了解到,敌人有两种属性:攻击值和生命值。需要我们选择最优的杀敌策略,使自己失去的生命值最少。那么这题的贪心策略就是:假设只面对两个敌人,我们应选择先杀敌A( 当敌A的攻击值乘以敌B的生命值要比敌B的攻击值乘以敌A的生命值要大)。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;


struct hero  
{
    int dps;//攻击值
    int hp;//生命值
}a[20];

int cmp(hero x,hero y)
{
    return (x.dps*y.hp>y.dps*x.hp);//贪心策略(攻击值大的先攻击,生命值小的先攻击)
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int sum=0,minhp=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a[i].dps,&a[i].hp);
            sum+=a[i].dps;
        }
        //printf("%d\n",sum);
        sort(a,a+n,cmp);//按贪心策略排序
        for(int i=0; i<n; i++)
        {
            minhp+=a[i].hp*sum;
            sum-=a[i].dps;
        }
        printf("%d\n",minhp);//最后结果


    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值