poj-Communication System

 

参考自:点击打开链接

描述

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices. 
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

 

输入

 

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

输出

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

样例输入

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

样例输出

0.649

解题思路:

枚举,将带宽的范围限制在所有带宽的最小和最大值之间。关键在于降低复杂度。由于B/P中间的B,P两个都是变量,首先固定住B,然后对于每个设备中寻找大于B时的最小价格,然后把所有设备的价格加起来,求最大值。

# include<stdio.h>
# include<algorithm>
using namespace std;

int a[200][200],b[200][200];
int num[200];

int main()
{
	int t,i,j;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			int n;
			scanf("%d",&n);
			int maxv=0,minv=123123123;

			for(i=0;i<n;i++)
			{
				scanf("%d",&num[i]);
				for(j=0;j<num[i];j++)
				{
					scanf("%d%d",&a[i][j],&b[i][j]);   
					if(a[i][j]>maxv)
						maxv=a[i][j];
					if(a[i][j]<minv)
						minv=a[i][j];
				}
			}
			
			double ans=0.0;
			for(int B=minv;B<=maxv;B++)
			{
				int sum=0;
				for(i=0;i<n;i++)
				{
				  int minCost=123123123;
				  for(j=0;j<num[i];j++)
				  {
				    if(a[i][j]>=B&&b[i][j]<minCost)
						minCost=b[i][j];
				  }
				   sum+=minCost;
				}
                
				if(1.0*B/sum>ans)
					ans=1.0*B/sum;
			}

			printf("%.3lf\n",ans);
			
		}	
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值