/*Description
Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet
connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity
with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to
connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum
amount of fiber needed to connect them all together. Each farm must connect to some other farm such
that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms,
N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element
shows the distance from on farm to another. Logically, they are N lines of N space-separated integers.
Physically, they are limited in length to 80 characters, so some lines continue onto others.
Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting
for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber
required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
描述
农民约翰已经当选市长的城市!他的竞选承诺之一就是把网络连接中的所有农场地区。当然,他需要你的帮助。
农民约翰下令高速连接他的农场,去分享他的连接与其他农民。成本降到最低,他想躺最少的光纤连接农场到其他所
有的农场。
给定的列表需要多少纤维连接每一对农场,你必须找到所需的最少的纤维连接起来。每个农场都必须连接到其他一
些农场,这样一个包可以从农场到其他任何一个农场。
任何两个农场之间的距离不会超过100000。
输入
输入包括几个案例。对于每个案例,第一行包含农场的数量,N(3 < = N < = 100)。第二行包含N * N conectivity
矩阵,其中每个元素显示了距离从农场到另一个。从逻辑上讲,他们是N行空格分隔的整数。身体上,他们在80个字符
长度是有限的,所以一些行继续到别人。当然,对角线是0,因为农场的距离我为这个问题本身并不有趣。*/
#include <stdio.h>
#include <string.h>
int e[105][105],d[105],final[105];
int n,sum;
void init()
{
memset(d,0x3f3f3f3f,sizeof(d));
memset(final,0,sizeof(final));
}
void prim()
{
int i,j,u,v;
d[0]=0;
while(1)
{
int min=0x3f3f3f3f;
u=-1;
for(i=0;i<n;i++)
{
if(d[i]<min&&!final[i])
{
u=i;
min=d[i];
}
}
if(u==-1)
break;
final[u]=1;
sum+=d[u];
for(j=0;j<n;j++)
{
if(!final[i]&&d[j]>e[u][j])
d[j]=e[u][j];
}
}
printf("%d\n",sum);
}
int main()
{
int i,j;
while(scanf("%d",&n)!=EOF)
{
sum=0;
init();
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
scanf("%d",&e[i][j]);
}
}
prim();
}
return 0;
}
Agri-Net
最新推荐文章于 2019-08-03 17:09:44 发布