poj 2184 Cow Exhibition

/*Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 
Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 
Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output

8


思路:往01背包上靠,可是这每个物品竟然有两个价值,难道是二维费用背包,可是又没有确定下
来的背包的容量。纠结纠结又纠结之后,队友传来消息:能不能用其中一个价值当做物品花费,
另一个价值当做真正的价值,这样做01背包,把背包容量不定,更新所有的0-100*2000,最后输出
最大的那个结果。
整理起来就是用TS做物品花费,TF做物品价值,做01背包。但是要注意有负数的存在,如果用一维数组
做背包,一定要注意第二重循环的顺序(因为背包的结果是用前一个状态转移来的,更新当前一层的数据
时不能更改上一层的数据)。如果是二维数组,就不用纠结循环的顺序,不过要更新小于当前物品花费
的数据。*/
#include <stdio.h>
#include <string.h>
#define max(a,b) a>b?a:b
int main()
{
	int i,j,s[2005],f[2005],dp[200005];
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&s[i],&f[i]);
		}
		memset(dp,-0x3f3f3f3f,sizeof(dp));
		dp[100000]=0;
		for(i=0;i<n;i++)
		{
			if(s[i]<0&&f[i]<0)
			continue;
			else if(s[i]<=0)
			{
				for(j=s[i];j<=200000+s[i];j++)
				{
					dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
				}
			}
			else
			{
				for(j=200000;j>=s[i];j--)
				{
					dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
				}
			}
		}
		int ans=-0x3f3f3f3f;
		for(i=100000;i<200000;i++)
		{
			if(dp[i]>=0)
			ans=max(ans,dp[i]+i-100000);
		}
		printf("%d\n",ans);
	 } 
	 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值