xp 系统安装 Microsoft .NET Framework v4.0 问题

        公司的一些项目用在vs2010下用wpf进行开发,用的是 .NET Framework v4.0的框架,虽说现在win8都出来了,大部分人也都用win7的操作系统了,但是很多单位,企业用的还都是xp,xp系统的稳定也备受很多企业朋友信任。在给各位企业朋友安装.NET Framework v4.0时也 遇到了很多问题,让我也纠结了很长世间,一次又一次的奇葩问题的出现,让我也是一次又一次的感觉自己知识的不足,好在最终问题都得到了解决,在此,我也总结一下我遇到的问题,以便遇到同样问题的朋友能少走点弯路;

1.  xp sp2的系统装不上 .NET Framework v4.0,当时也是经过了无数次的重装,在网上也找了很多资料,最终发现是 sp2缺少Windows 图像处理组件,必须先下载补丁,将补丁安装上,才能将.NET Framework v4.0安装上。下载地址:http://www.microsoft.com/zh-cn/download/details.aspx?id=32 

下载wic_x86_chs.exe文件,下载后安装,然后再装 .NET Framework v4.0 ,ok 这样就能安装成功了!

2. 我一直以为只有xp sp2装不上  .NET Framework v4.0,同时找到了解决方法,感觉很兴奋,不过最后我又遇到了装不上 .NET Framework v4.0的情况,但是系统不是xp sp2,而是xp sp3,最终经过多次的研究发现,上网查资料,和同事,朋友一起研究发现一个规律,大部分都是12年8月份以后的xp sp3装不上,最后在网上找资料说是微软更新补丁,需要将更新的补丁卸载后才能安装,我的天,这么多补丁,鬼知道是该卸载哪一个,不过最终还是找到了解决办法。主要是文件更新造成的,需要将你的 .NET Framework v4.0,解压,解压后再文件夹内找到这两个文件(RGB9Rast_x86.msi和RGB9Rast_x64.msi),如过你的电脑是32位的就用RGB9Rast_x86.msi这个文件,如过64位的,就用RGB9Rast_x64.msi的那个文件.这两个文件需要手动安装,安装命令如下:MSIEXEC / I RGB9RAST_x86.msi / QN ALLUSERS = 1 REBOOT = REALLYSUPPRESS,更新过之后,就能在安装.NET Framework v4.0了。

下面我是我在网上找到的一段原话:

如果您遇到上述错误在尝试安装RGB9RAST。MSI作为。NET Framework 3.0的,3.0 SP1的一部分,
在Windows XP或Windows Server 2003的3.5或3.5 SP1安装程序,那么我建议尝试手动安装RGBRAST9。MSI与运行NET Framework安装之前,以下命令行语法:MSIEXEC / I RGB9RAST_x86.msi / QN ALLUSERS = 1 REBOOT = REALLYSUPPRESS
当你手动安装RGB9RAST的。msi,可以运行。NET Framework安装,它会检测到系统中已经有RGB9RAST安装,它会跳过试图安装它,并继续安装
,需要在余下的。NET Framework组件的制度。
注 - 您可以使用在。NET Framework 3.0中的说明和3.5部署指南下载NET Framework安装包解压MSI需要上面的命令行的RGB9RAST。。 下面是部署指南的位置


©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值