题目描述:
大家都知道一些办公软件有自动将字母转换为大写的功能。输入一个长度不超过 100 字符串,有可能带空格。要求将该字符串中的所有小写字母变成大写字母并输出。
样例数据:
样例输入:
talk is cheap, show me the code!
样例输出:
TALK IS CHEAP, SHOW ME THE CODE!
这题有两个思路
思路1:
C++里面有个自带的函数可以帮助我们实现大小写转换,就不需要再去用循环,一行代码就可以解决,非常的方便! 假设我们要a这个字符串小写转大写,那么代码如下
transform(a.begin(),a.end(),a.begin(),::toupper);
然后是思路1的CODE:
#include<bits/stdc++.h>
using namespace std;
int main(){
string a;
getline(cin,a);
//因为题目中有说可能会有空格,所以不能用cin,只能用getline
transform(a.begin(),a.end(),a.begin(),::toupper);
cout<<a;
return 0;
}
然后是思路2:
直接用ASCLL码的思路去做这个,普及一下,ASCII码表的空格是32,大写A是65,小写a是97。
思路2的CODE:
#include<bits/stdc++.h>
using namespace std;
int main(){
string s;
getline(cin, s);
//因为题目中有说可能会有空格,所以不能用cin,只能用getline
for (itn i=0; i<s.size(); i++){
if (s[i]>='a' && s[i]<='z'){
s[i]-=32;
//划重点:小写字母转大写字母是减32,大写字母转小写字母是加32。
}
}
cout << s;
return 0;