ubuntu16.04下将tensorflow1.4升级到1.6

1.卸载cuda8.0

Tensorflow 1.6 需要 CUDA9.0,原来装的是 8.0 。这就需要卸载一个、安装一个。 

官方的方案: 
http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#handle-uninstallation

卸载 CUDA 使用:

$ sudo /usr/local/cuda-8.0/bin/uninstall_cuda_8.0.pl

2.安装cuda9.0

下载 CUDA 9.0: https://developer.nvidia.com/cuda-release-candidate-download 

文件1.6G,文件名字是cuda_9.0.176_384.81_linux.run,文件目录下打开一个终端

执行如下命令:

sudo sh cuda_9.0.176_384.81_linux.run
可能会出现一个类似使用说明的东西,一直点回车看完就行了,然后会出现一些选项问题,除了Install NVIDIA Accelerated Graphics Driver for linux(因为已经提前安装了显卡驱动,所以这里选择不安装)? 选择n(no)以外,其他的都选y(yes)就行了,安装结束后,我们要开始添加环境变量了,首先随便打开一个终端,执行以下代码打开环境变量:
sudo gedit ~/.bashrc(or .profile)

在 .bashrc 文件末尾处加上CUDA 9.0的环境变量,如下代码:

export PATH=/usr/local/cuda-9.0/bin:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda-9.0/lib64$LD_LIBRARY_PATH

点击右上角的Save(保存)按键。

测试CUDA 9.0 是否安装成功:

打开终端,先cd 到 下面的目录,再执行 sudo make,接着执行 ./deviceQuery,代码如下:

~$ cd /usr/local/cuda-9.0/samples/1_Utilities/deviceQuery
/usr/local/cuda-9.0/samples/1_Utilities/deviceQuery$ sudo make
/usr/local/cuda-9.0/samples/1_Utilities/deviceQuery$ ./deviceQuery

出现如下,这就说明,你的CUDA 9.0安装成功,且环境变量也配置完成了。


3.安装cuDNN v7 

cuDNN v7 for 9.0: https://developer.nvidia.com/rdp/cudnn-download 。官方文档表示 cuDNN 的升级不会冲突,直接安装就好。 

下载完成后,解压cuDNN的压缩文件,名字是cudnn-9.0-linux-x64-v7.tgz,解压完成后,进行如下代码操作。

~$ sudo cp cuda/include/cudnn.h /usr/local/cuda-9.0/include
~$ sudo cp cuda/lib64/libcudnn* /usr/local/cuda-9.0/lib64
~$ sudo chmod a+r /usr/local/cuda/include/cudnn.h /usr/local/cuda-9.0/lib64/libcudnn*

这样我们就完成了cuDNN 7.0 的安装。


4.安装tensorflow1.6

卸载tensorflow1.4:

sudo pip uninstall tensorflow==1.4

随便打开一个终端,运行代码,Python 3 

sodu pip3 install tensorflow-gpu==1.6

测试tf1.6是否装好:

Python3

import tensorflow as tf

tf.__version__

阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭