点击打开链接
Description
A numeric sequence of
ai is ordered if
a1 <
a2 < ... <
aN. Let the subsequence of the given numeric sequence (
a1,
a2, ...,
aN) be any sequence (
ai1,
ai2, ...,
aiK), where 1 <=
i1 <
i2 < ... <
iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7 1 7 3 5 9 4 8
Sample Output
4&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
最长上升子序列;步骤是下面画的;
1
1 7
1 3
1 3 5
1 3 5 9
1 3 4 9
1 3 4 8
就是这样实现的
#include<stdio.h>
int main()
{
int i,j,k,m,n,flag;
int g[1005],a[1005];
while(scanf("%d",&m)!=EOF)
{
for(i=0;i<m;i++)
scanf("%d",&g[i]);
n=1;
a[0]=g[0];
for(i=1;i<m;i++)
{
flag=0;
for(j=0;j<=n;j++)
{
if(g[i]<=a[j]&&j<=n)
{
a[j]=g[i];
flag=1;
}
else if(g[i]>a[j]&&j==n)
{
a[j+1]=g[i];
n++;
flag=1;
}
if(flag)
break;
}
}
printf("%d\n",n);
}
return 0;
}