R(N)

http://acm.hdu.edu.cn/showproblem.php?pid=3835

Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
 

Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).
 

Output
For each N, print R(N) in one line.
 

Sample Input
  
  
2 6 10 25 65
 

Sample Output
  
  
4 0 8 12 16
Hint
For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
 &&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
此题给的数据很大~10^9,用双层循环肯定要超时,因此,想到了毛哥哥的算法,用判断代替一层循环;节省很多时间;15ms
#include<stdio.h>
#include<math.h>
int main()
{
	int i,j,k,m,n,sum;
	while(scanf("%d",&m)!=EOF)
	{
		sum=0;
		n=(int)(sqrt(m)+1);
		if(m==0)
		{
		    printf("1\n");
		    continue;
		}
		for(i=0;i<n;i++)
		{
			k=(int)(sqrt(m-i*i));
			if(k*k+i*i==m)
			{
				if(k==i)
				sum+=4;
				else if(k<i)
				sum+=8;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值