Triangle

点击打开链接
Description

A lattice point is an ordered pair (x, y) where x and y are both integers. Given the coordinates of the vertices of a triangle (which happen to be lattice points), you are to count the number of lattice points which lie completely inside of the triangle (points on the edges or vertices of the triangle do not count).

Input

The input test file will contain multiple test cases. Each input test case consists of six integers x1, y1, x2, y2, x3, and y3, where (x1, y1), (x2, y2), and (x3, y3) are the coordinates of vertices of the triangle. All triangles in the input will be non-degenerate (will have positive area), and −15000 ≤ x1, y1, x2, y2, x3, y3 ≤ 15000. The end-of-file is marked by a test case with x1 = y1 = x2 = y2 = x3 = y3 = 0 and should not be processed.

Output

For each input case, the program should print the number of internal lattice points on a single line.

Sample Input

0 0 1 0 0 1
0 0 5 0 0 5
0 0 0 0 0 0
Sample Output

0
6


#include<stdio.h>
#include<math.h>
struct point 
{
	int x,y;
};
double area(point a,point b,point c)
{
	return fabs(a.x*b.y+b.x*c.y+c.x*a.y-a.x*c.y-b.x*a.y-c.x*b.y)*0.5;
}
int gcd(int m,int n)//求边上的整数点个数;
{
	if(m<0)
	m=-m;
	if(n<0)
	n=-n;
	if(m<n)
	{
		m^=n^=m^=n;
	}
	if(n==0)return m;
	else return gcd(n,m%n);
}
int main()
{
	int i,j,k,m,n,aa,bb,cc;
	point a,b,c;
	while(scanf("%d%d%d%d%d%d",&a.x,&a.y,&b.x,&b.y,&c.x,&c.y)!=EOF)
	{
		if(a.x==0&&b.x==0&&c.x==0&&a.y==0&&b.y==0&&c.y==0)
		break;
		aa=gcd(b.x-a.x,b.y-a.y);
		bb=gcd(c.x-a.x,c.y-a.y);
		cc=gcd(c.x-b.x,c.y-b.y);
		k=(int)(area(a,b,c)-(aa+bb+cc)/2.0+1);
		printf("%d\n",k);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值