HDU-5971 Wrestling Match

Problem Description

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into "good player" and "bad player".

 

Input

Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known "good players" and the number of known "bad players".In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a "good player" number.The last line contains Y different numbers.Each number represents a known "bad player" number.Data guarantees there will not be a player number is a good player and also a bad player.

 

Output

If all the people can be divided into "good players" and "bad players”, output "YES", otherwise output "NO".

 

Sample Input

 

5 4 0 0

1 3

1 4

3 5

4 5

5 4 1 0

1 3

1 4

3 5

4 5

2

 

Sample Output

NO
YES

题目大意:

 

给出 n 个人,m 场 比赛, x 个已经确定的好人 , y  个已经确定的坏人。

每场比赛由 好人和坏人 组成。

问是否能够将每个人划分成好人或者坏人。

 

思路:

 

dfs 染色。先从 已经确定的人 开始 染色与其相关的人。矛盾就 NO

然后对于不确定的人,枚举染色。 如果矛盾就是 NO

如果最后还存在不确定的,那么就是 NO 

否则就是 YES 。

My code:

#include <bits/stdc++.h>
using namespace std;

const int N = 1e5+5;
int a[N],b[N],vis[N];
int main()
{
        int n,m,x,y,k;
    while(scanf("%d%d%d%d",&n,&m,&x,&y)!=EOF)
    {
        /*初始化*/
        memset(vis,-1,sizeof(vis));
        for(int i=1;i<=m;i++)
            scanf("%d%d",&a[i],&b[i]);
        /*好人定义为1*/
        for(int i=1;i<=x;i++)
        {
            scanf("%d",&k);
            vis[k]=1;
        }
        /*坏人定义为0*/
        for(int i=1;i<=y;i++)
        {
            scanf("%d",&k);
            vis[k]=0;
        }
        int flag=0;
        for(int i=1;i<=m;i++)
        {
            if(vis[a[i]]==-1 && vis[b[i]] == -1)
                vis[a[i]]=1,vis[b[i]]=0;
            else if(vis[a[i]]!=-1 && vis[b[i]]==-1)
                vis[b[i]]=vis[a[i]]^1;
            else if(vis[a[i]]==-1 && vis[b[i]]!=-1)
                vis[a[i]]=vis[b[i]]^1;
            else if(vis[a[i]]==vis[b[i]] && vis[a[i]]!=-1) //a==b,有悖题意
                flag=1;
        }
        for(int i=1;i<=n;i++)
        {
            if(vis[i]==-1)
                flag=1;
        }
        if(flag==1) puts("NO");
        else puts("YES");
    }
    return 0;
}

 

 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值