Week12 作业 A - 必做题 - 1 HDU - 1029

给出n个数,zjm想找出出现至少(n+1)/2次的数, 现在需要你帮忙找出这个数是多少?

Input
本题包含多组数据:
每组数据包含两行。
第一行一个数字N(1<=N<=999999) ,保证N为奇数。
第二行为N个用空格隔开的整数。
数据以EOF结束。

Output
对于每一组数据,你需要输出你找到的唯一的数。

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

#include<stdio.h>
int L[500005];
int count[500005];

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int current=0;
		int target=(n+1)/2;
		int a;
		for(int i=0;i<n;i++){
			scanf("%d",&a);
			int found=0;
			int j=0;
			for(;j<current;j++){
				if(L[j]==a){
					count[j]++;
					found=1;
					break;
				}
			}
			if(!found){
				count[current]=1;
				L[current]=a;
				current++;
			}
		}
		for(int i=0;i<current;i++){
			if(count[i]>=target){
				printf("%d\n",L[i]);
			}
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值