POJ - 1751 Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i  th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 
Sample Input
9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7
8 3
刚开始学Kruskal,都是套路 大笑,不过这道题遇到了点小麻烦, 抓狂TLT......  某同学告诉我说,不能用sqrt,,,我改了,然后还是 快哭了

其实明知道把修好的路的w变为0,用两个for循环肯定超时~~~但我想不出来其它的方法。。。。

还是大神厉害,直接把修好的路合并,然后在进行其他的,因为变为o在排序还是先合并它们。。。

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct note
{
    double x,y;
} q[1000];
struct data
{
    int u,v;
    double w;
} Q[1000000];
int f[1000];
int cmp(data a,data b)
{
    return a.w<b.w;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(int v,int u)
{
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int m=1;
        for(int i=1; i<=n; i++)
            scanf("%lf%lf",&q[i].x,&q[i].y);
        for(int i=1; i<=n; i++)
            f[i]=i;
        for(int i=1; i<n; i++)
            for(int j=i+1; j<=n; j++)
            {
                double x=sqrt((q[i].x-q[j].x)*(q[i].x-q[j].x)+(q[i].y-q[j].y)*(q[i].y-q[j].y));
                Q[m].u=i,Q[m].v=j,Q[m++].w=x;
            }
        int t;
        scanf("%d",&t);
        int a,b;
        for(int i=1; i<=t; i++)
        {
            scanf("%d%d",&a,&b);
            merge(a,b);   //这是重点,先合并它们!!!。省去了找路的麻烦,还有排序
        }
        sort(Q+1,Q+m,cmp);
        int num=0;
        for(int i=1; i<m; i++)
        {
            if(merge(Q[i].u,Q[i].v))
            {
                //num++;     //可以省时
                if(Q[i].w!=0)
                    printf("%d %d\n",Q[i].u,Q[i].v);
            }
            //if(num==n-1)break;合并之前,到n-1就行了,然后先合并一部分,就更小于它啦~~~
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值