1388. Quicksum
Constraints
Time Limit: 1 secs, Memory Limit: 32 MB
Description
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.
For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.
A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":
ACM: 1*1 + 2*3 + 3*13 = 46 MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650
Input
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.
Output
For each packet, output its Quicksum on a separate line in the output.
Sample Input
ACM MID CENTRAL REGIONAL PROGRAMMING CONTEST ACN A C M ABC BBC #
Sample Output
46 650 4690 49 75 14 15
涉及字符串,难度0。
#include <iostream>
#include <string>
using namespace std;
int main() {
string n;
while (getline(cin, n) && n[0] != '#') {
int sum = 0;
for (unsigned i = 1; i <= n.size(); i++) {
if (n[i-1] != ' ') {
sum = sum + i * (n[i - 1] - 'A' + 1);
}
}
cout << sum << endl;
}
}
注意:
getline的使用方法
1.该头文件为#include <string>istream& getline ( istream &is , string &str , char delim );istream& getline ( istream& , string& );is 进行读入操作的输入流str 存储读入的内容delim 终结符
2.该头文件为#include <iostream>成员函数:cin.getline(字符指针,字符个数N,结束符);功能是:一次读取多个字符(包括空白字符),直到读满N-1个,或者遇到指定的结束符为止(默认的是以'\n'结束)。