微软笔试-Divisors

时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

Given an integer n, for all integers not larger than n, find the integer with the most divisors. If there is more than one integer with the same number of divisors, print the minimum one.

输入

One line with an integer n.

For 30% of the data, n ≤ 103

For 100% of the data, n ≤ 1016

输出

One line with an integer that is the answer.

样例输入
100
样例输出
60

代码区:

// MS.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include <iostream>
#include <math.h>
#include <set>
#include <algorithm>
using namespace std;
int primes[14]{ 2,3,5,7,11,13,17,19,23,29,31,37,41,43};
int maxdivs;
long long result;
long long N;
void DFS(long long now,int divs, int primeIndex, int lastni)
{
	if (now > N)
		return;
	if (maxdivs < divs || (maxdivs == divs&&now < result))
	{
		maxdivs = divs;
		result = now;
	}
	int i = 1;
	while (now*pow(primes[primeIndex], i) <= N && i <= lastni)
	{
		long long newvalue = now*pow(primes[primeIndex],i);
		DFS(newvalue, divs*(i + 1), primeIndex + 1, i);
		i++;
	}
}
int main()
{
	while (cin >> N)
	{
		int maxni = log2(N);
		result = 1;
		maxdivs = 0;
		for (int i = 0; i <= maxni; ++i)
		{
			DFS(pow(2, i), i + 1,1, i);
		}
		cout << result << endl;
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值