[PAT]1004. Counting Leaves (30)@Java

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output

0 1

调试程序花了很长时间,要注意的是:一个程序中,Scanner的nextInt,nextLine不能混用

package go.jacob.day825;

import java.util.ArrayList;
import java.util.LinkedList;
import java.util.List;
import java.util.Queue;
import java.util.Scanner;

public class Demo1 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		// N为所有节点数,M为所有非叶节点数
		//Scanner的nextInt方法和nextLine不能混用!!
		String[] s=sc.nextLine().split(" ");
		int N = Integer.parseInt(s[0]), M = Integer.parseInt(s[1]);
		// 用一个ArrayList数组来保存每一个节点的子节点.节点从1开始,所以lists大小为N+1
		ArrayList<Integer>[] lists = new ArrayList[N + 1];
		for (int i = 0; i <= N; i++) {
			lists[i] = new ArrayList<Integer>();
		}
		// 循环读取输入
		for (int i = 0; i < M; i++) {
			// 将字符串以空格分割,结果为String数组
			String str=sc.nextLine();
			String[] strs = str.split(" ");
			for (int j = 2; j < strs.length; j++) {
				lists[Integer.parseInt(strs[0])].add(Integer.parseInt(strs[j]));
			}
		}
		// 广度优先搜索
		List<Integer> res = bfs(lists);

		for (int i = 0; i < res.size() - 1; i++) {
			System.out.print(res.get(i) + " ");
		}
		System.out.print(res.get(res.size() - 1));
	}

	private static List<Integer> bfs(ArrayList<Integer>[] lists) {
		// 树的层序遍历,需要借助队列完成
		Queue<Integer> queue = new LinkedList<Integer>();
		// res存储每层叶节点数
		List<Integer> res = new ArrayList<Integer>();
		queue.add(1);
		while (!queue.isEmpty()) {
			int count = 0, size = queue.size();
			for (int i = 0; i < size; i++) {
				int tmp = queue.poll();
				if (lists[tmp].isEmpty()) {
					count++;
				} else {
					for (Integer num : lists[tmp])
						queue.add(num);
				}

			}
			res.add(count);
		}
		return res;

	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值