[PAT]1018. Public Bike Management (30)@Java

1018. Public Bike Management (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.


Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci (i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0


牛客网能够AC,PAT只有17分。后续会进行修改


package go.jacob.day924;

import java.util.ArrayList;
import java.util.Arrays;
import java.util.Collections;
import java.util.Comparator;
import java.util.Scanner;

/**
 * [编程题]Public Bike Management (30)
 * 
 * @author Jacob
 * 
 *         注意点:自行车只能在去的路径上投放,回来的路上不能投放
 * 
 * 
 */
public class Demo1 {
	static int[] dist;// 存储到起点的距离
	static int[] bikes;
	static boolean[] visited;// 每个站点是否被访问过
	static ArrayList[] edgeTo;// 每个点的上一个节点(可能有多个)
	static int[][] map;// map存储所有的边

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int cMax = sc.nextInt(), staNum = sc.nextInt();
		int proSta = sc.nextInt(), roadNum = sc.nextInt();
		bikes = new int[staNum + 1];// 编号从1到N
		dist = new int[staNum + 1];// 编号从1到N
		visited = new boolean[staNum + 1];
		edgeTo = new ArrayList[staNum + 1];
		for (int i = 1; i <= staNum; i++) {
			bikes[i] = sc.nextInt();
		}
		for (int i = 0; i <= staNum; i++) {
			dist[i] = Integer.MAX_VALUE;
		}

		map = new int[staNum + 1][staNum + 1];
		for (int i = 0; i <= staNum; i++) {
			for (int j = 0; j < staNum; j++) {
				if (i == j)
					map[i][j] = 0;
				else
					map[i][j] = Integer.MAX_VALUE;
			}
		}
		for (int i = 0; i < roadNum; i++) {
			int a = sc.nextInt(), b = sc.nextInt();
			map[a][b] = map[b][a] = sc.nextInt();
		}

		dijkstra(0, proSta, cMax, staNum);

		// 找到所有的路径
		ArrayList<ArrayList<Integer>> list = new ArrayList<ArrayList<Integer>>();
		ArrayList<Integer> path = new ArrayList<Integer>();
		findPath(0, proSta, path, list);
		// 现在list中存放着左右路径,对所有路径的所需车辆数进行计算
		NeedBike[] needBike = new NeedBike[list.size()];
		for (int i = 0; i < list.size(); i++) {
			needBike[i] = calculateBike(list.get(i), cMax);
		}
		Arrays.sort(needBike, new Comparator<NeedBike>() {

			@Override
			public int compare(NeedBike o1, NeedBike o2) {
				if (o1.needBike != o2.needBike)
					return o1.needBike - o2.needBike;
				else
					return o1.backBike - o2.backBike;
			}

		});
		// 输出结果
		NeedBike res = needBike[0];
		System.out.print(res.needBike);

		ArrayList<Integer> road = res.road;
		System.out.print(" " + road.get(road.size() - 1));
		for (int i = road.size() - 2; i >= 0; i--) {
			System.out.print("->" + road.get(i));
		}
		System.out.print(" " + res.backBike);
	}

	/*
	 * 路径是逆序的
	 */
	private static NeedBike calculateBike(ArrayList<Integer> array, int cMax) {
		NeedBike res = new NeedBike();
		int needBike = 0, curBike = 0;
		int backBike = 0;
		// 因为array.get(array.size()-1)是主站,不需要自行车
		for (int i = array.size() - 2; i >= 0; i--) {
			// 车辆不够,需要从主站中获取
			if (bikes[array.get(i)] + curBike < cMax / 2) {
				needBike += cMax / 2 - bikes[array.get(i)] - curBike;
				curBike = 0;
			} else {// 车辆足够
				curBike = bikes[array.get(i)] + curBike - cMax / 2;
			}
			if (i == 0)
				backBike = curBike;
		}
		res.needBike = needBike;
		res.backBike = backBike;
		res.road = array;
		return res;
	}

	private static void findPath(int res, int proSta, ArrayList<Integer> path, ArrayList<ArrayList<Integer>> list) {
		if (res == proSta) {
			path.add(res);
			list.add(new ArrayList<Integer>(path));
			path.remove(path.size() - 1);
			return;
		}

		ArrayList<Integer> pre = edgeTo[proSta];
		for (int a : pre) {
			path.add(proSta);
			findPath(res, a, path, list);
			path.remove(path.size() - 1);
		}
	}

	/*
	 * dijkstra算法,找到最短路径(可能有多条) 所以用arrayList保存每个站点的上一个站
	 */
	private static void dijkstra(int res, int dest, int cMax, int staNum) {
		dist[res] = 0;
		int curSta = res;
		while (true) {
			if (curSta == -1)
				break;
			visited[curSta] = true;
			for (int i = 0; i <= staNum; i++) {
				// curSta加入已遍历集合后,更新所有站点的路径
				 (map[curNode][i] + dist[curNode] < dist[i])会溢出
				if (!visited[i] && map[curSta][i] <= dist[i] - dist[curSta]) {
					if (edgeTo[i] == null)
						edgeTo[i] = new ArrayList<Integer>();
					if (map[curSta][i] + dist[curSta] < dist[i]) {
						dist[i] = map[curSta][i] + dist[curSta];
						edgeTo[i].clear();
						edgeTo[i].add(curSta);
					} else
						edgeTo[i].add(curSta);
				}
			}
			int min = Integer.MAX_VALUE, index = -1;
			for (int i = 0; i <= staNum; i++) {
				if (!visited[i] && dist[i] < min) {
					min = dist[i];
					index = i;
				}
			}
			curSta = index;

		}

	}
}

class NeedBike {
	int needBike;
	int backBike;
	ArrayList<Integer> road;

	@Override
	public String toString() {
		return "NeedBike [needBike=" + needBike + ", backBike=" + backBike + "]";
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值