题目详情
MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.
In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.
In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determine the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strong when i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.
Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.
Input
The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.
Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would normally be specified). The maximum value for N will be 1000.
Output
The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.
输入样例
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
输出样例
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)
题目大意
大致意思就是先给出一个密码,然后再给出几个猜测的密码,算出每个猜测密码和正确密码数字强匹配和弱匹配的个数。当猜测密码的数字和正确密码中的数字数值相同且所处位置相同时即判断为强匹配,当猜测密码的数字和正确密码中的数字数值相同但所处位置不同时则判断为弱匹配。题目总体不难。
测试样例分析
第一个测试样例:(红色加粗为强匹配,蓝色加粗为弱匹配)
正确密码: 1 3 5 5
猜测密码(1):1 1 2 3
提示为:(1,1)//即一个强匹配,一个弱匹配
正确密码: 1 3 5 5
猜测密码(2): 4 3 3 5
提示为:(2,0)//2个强匹配,,0个弱匹配
第二个测试样例:
正确密码: 1 2 2 2 4 5 6 6 6 9
猜测密码(1):1 2 3 4 5 6 7 8 9 1
提示为:(2,4)//2个强匹配,4个弱匹配
正确密码: 1 2 2 2 4 5 6 6 6 9
猜测密码(2):1 1 2 2 3 3 4 4 5 5
提示为:(3,2)//3个强匹配,2个弱匹配
题目分析
先找到正确密码序列和猜测密码序列中的相同数字并取最小值(如果A序列有2个1,但是B序列只有1个1则取1个),这就是最大的强匹配数字,然后两个序列再逐个匹配,如果数值相同且所处位置也相同则强匹配数加1(初始为0)。最后弱匹配数 = 最大强匹配数 - 真正强匹配数。然后按照题目要求输出即可。
AC代码
#include<iostream>
#include<vector>
using namespace std;
vector<int>num;//正确密码
vector<int>n(10, 0);
vector<int>guess;//猜测密码
vector<int>g(10, 0);
char s[10010];
int main()
{
int count = 0;
int col;
while (cin >> col)
{
if (col == 0)
break;
cout << "Game " << ++count << ":" << endl;
int code;
while (cin >> code)//正确密码
{
if(code == 0)
break;
num.push_back(code);
n[code]++;
if (num.size() == col)
break;
}
int i = 0, p_num = 0, w_num = 0, sum = 0;
while (cin >> code)//猜测密码
{
if (code == 0)
{
cin.get(s, 2 * col + 1);
break;
}
if (num[i++] == code)
p_num++;//强匹配数加1
guess.push_back(code);
g[code]++;
if (guess.size() == col)
{
for (int j = 0; j < 10; j++)
{
if (n[j] && g[j])
{
sum += min(n[j], g[j]);//最大强匹配数取最小值
}
}
w_num = sum - p_num;//弱匹配数
cout << " (" << p_num << "," << w_num << ")" << endl;
guess.clear();//清空
g.assign(10, 0);//重新设置
i = 0;
p_num = 0;
w_num = 0;
sum = 0;
}
}
num.clear();
n.assign(10, 0);
}
return 0;
}
zjr